summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIskren Slavov <iskren.s@gmail.com>2010-04-19 17:43:21 +0300
committerIskren Slavov <iskren.s@gmail.com>2010-04-19 17:43:21 +0300
commit16b5a27351a2b9c2ef70dd10073bdf5cada30ba3 (patch)
tree29c2fd0bbc4e5a9ec322575edca36dcac3f157d1 /app-emulation
parentliferea-1.7.4: removed lua support, added liferea-1.6.3 bump (diff)
downloadwish-16b5a27351a2b9c2ef70dd10073bdf5cada30ba3.tar.gz
wish-16b5a27351a2b9c2ef70dd10073bdf5cada30ba3.tar.bz2
wish-16b5a27351a2b9c2ef70dd10073bdf5cada30ba3.zip
add wine-1.1.43, add lirc-0.8.6-r3 (compiles with kernel 2.6.33+)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine/Manifest8
-rw-r--r--app-emulation/wine/files/wine-1.1.15-winegcc.patch55
-rw-r--r--app-emulation/wine/metadata.xml20
-rw-r--r--app-emulation/wine/wine-1.1.43.ebuild178
4 files changed, 261 insertions, 0 deletions
diff --git a/app-emulation/wine/Manifest b/app-emulation/wine/Manifest
new file mode 100644
index 0000000..836850a
--- /dev/null
+++ b/app-emulation/wine/Manifest
@@ -0,0 +1,8 @@
+AUX wine-1.1.15-winegcc.patch 1550 RMD160 086fbdd7dbe5da98c3457f00cb30705150d58b1f SHA1 0aa5a9d0947e15af9fe103797a0c993cbb3eedab SHA256 fcf4a0578774d817b8de094abae85e370683a77805a59efe6c5f7b8b87935de9
+DIST wine-1.1.43.tar.bz2 16760374 RMD160 043e49e12e0892bd08b4c6ba6adee267f6e8d8d3 SHA1 2f77eab13f29b7942d5507ef925c40ff1ecfd3a5 SHA256 20656ac69a628341ecce55a72d02ee93e20e0c2a4bf6df94336738f1f1ff793a
+DIST wine_gecko-1.0.0-x86.cab 8119486 RMD160 57618dbffa7b7226dcd44f86c3c569ab8a5ff938 SHA1 afa22c52bca4ca77dcb9edb3c9936eb23793de01 SHA256 7ddf697677506fb164c52771864e32dd69a359ed855b2efbc51340de2376c99c
+DIST winepulse-0.34-winecfg.patch 13066 RMD160 7a05298f68bbdcc80596e931c47b178484ae9c5a SHA1 1a495dd6fd93573a274d525af8b74713f57a7d18 SHA256 a2925d4a02db57ed8961b45b80a0f966fed1f499120e094156a4c51086e47cdc
+DIST winepulse-0.35-configure.ac.patch 2826 RMD160 e419d43667be01af9b24a0e46822c41572a6ff9d SHA1 4943381128fd9555280884e2bb5867be4a8731d9 SHA256 837bffaaddb6b7b0a474c7262a57f12e250e135cf6228dde1a22849f66de1250
+DIST winepulse-0.36.patch 101815 RMD160 9a20076436a7e49c317bc624dd71b61c93acddff SHA1 aa6a4c9d4619f8452aad8c457c879769cab8f8fc SHA256 7508b171bfecb461ecb464426cb4bcd9c3ff77645b787fcbf61e27dd34fe1b05
+EBUILD wine-1.1.43.ebuild 4929 RMD160 137952e182146400766d3fb76303436d9f7c5e9e SHA1 92e07587492d71dd85463864411f6f9b4ee2e417 SHA256 a84109de59cfbd7e1baa84770507bbc9653311aed072ed4075448cd5c3961a00
+MISC metadata.xml 1333 RMD160 fe0a0c8ec639987ff6c06f7a9e47a391defb5478 SHA1 421e3087a3f122fa15283d82429f1d315fba313a SHA256 edaaae36cc5924ea3be49d2d3628e5de555b87b2bee44685797efee72f599902
diff --git a/app-emulation/wine/files/wine-1.1.15-winegcc.patch b/app-emulation/wine/files/wine-1.1.15-winegcc.patch
new file mode 100644
index 0000000..6e5bb22
--- /dev/null
+++ b/app-emulation/wine/files/wine-1.1.15-winegcc.patch
@@ -0,0 +1,55 @@
+http://bugs.gentoo.org/260726
+
+--- wine-1.1.15/tools/winegcc/winegcc.c
++++ wine-1.1.15/tools/winegcc/winegcc.c
+@@ -215,10 +215,13 @@
+ strarray* files;
+ };
+
++#undef FORCE_POINTER_SIZE
+ #ifdef __i386__
+ static const enum target_cpu build_cpu = CPU_x86;
++#define FORCE_POINTER_SIZE
+ #elif defined(__x86_64__)
+ static const enum target_cpu build_cpu = CPU_x86_64;
++#define FORCE_POINTER_SIZE
+ #elif defined(__sparc__)
+ static const enum target_cpu build_cpu = CPU_SPARC;
+ #elif defined(__ALPHA__)
+@@ -968,6 +971,9 @@
+ opts.linker_args = strarray_alloc();
+ opts.compiler_args = strarray_alloc();
+ opts.winebuild_args = strarray_alloc();
++#ifdef FORCE_POINTER_SIZE
++ opts.force_pointer_size = sizeof(size_t);
++#endif
+
+ /* determine the processor type */
+ if (strendswith(argv[0], "winecpp")) opts.processor = proc_cpp;
+--- wine-1.1.15/tools/winebuild/main.c
++++ wine-1.1.15/tools/winebuild/main.c
+@@ -50,10 +50,13 @@
+ int link_ext_symbols = 0;
+ int force_pointer_size = 0;
+
++#undef FORCE_POINTER_SIZE
+ #ifdef __i386__
+ enum target_cpu target_cpu = CPU_x86;
++#define FORCE_POINTER_SIZE
+ #elif defined(__x86_64__)
+ enum target_cpu target_cpu = CPU_x86_64;
++#define FORCE_POINTER_SIZE
+ #elif defined(__sparc__)
+ enum target_cpu target_cpu = CPU_SPARC;
+ #elif defined(__ALPHA__)
+@@ -574,6 +577,10 @@
+ signal( SIGTERM, exit_on_signal );
+ signal( SIGINT, exit_on_signal );
+
++#ifdef FORCE_POINTER_SIZE
++ force_pointer_size = sizeof(size_t);
++#endif
++
+ output_file = stdout;
+ argv = parse_options( argc, argv, spec );
+
diff --git a/app-emulation/wine/metadata.xml b/app-emulation/wine/metadata.xml
new file mode 100644
index 0000000..6b6db18
--- /dev/null
+++ b/app-emulation/wine/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>wine</herd>
+<longdescription>
+Wine is an Open Source implementation of the Windows API on top of X and Unix.
+
+Think of Wine as a compatibility layer for running Windows programs. Wine does not require Microsoft Windows, as it is a completely free alternative implementation of the Windows API consisting of 100% non-Microsoft code, however Wine can optionally use native Windows DLLs if they are available. Wine provides both a development toolkit for porting Windows source code to Unix as well as a program loader, allowing many unmodified Windows programs to run on x86-based Unixes, including Linux, FreeBSD, and Solaris.
+</longdescription>
+<use>
+ <flag name='capi'>Enable ISDN support via CAPI</flag>
+ <flag name='custom-cflags'>Bypass strip-flags; use are your own peril</flag>
+ <flag name='gecko'>Add support for the Gecko engine when using iexplore</flag>
+ <flag name='perl'>Install helpers written in perl (winedump/winemaker)</flag>
+ <flag name='samba'>Add support for NTLM auth. see
+ http://wiki.winehq.org/NtlmAuthSetupGuide and
+ http://wiki.winehq.org/NtlmSigningAndSealing</flag>
+ <flag name='win64'>Build a 64bit version of Wine (won't run Win32 binaries)</flag>
+</use>
+</pkgmetadata>
diff --git a/app-emulation/wine/wine-1.1.43.ebuild b/app-emulation/wine/wine-1.1.43.ebuild
new file mode 100644
index 0000000..c96fde2
--- /dev/null
+++ b/app-emulation/wine/wine-1.1.43.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.1.42.ebuild,v 1.1 2010/04/10 20:01:12 vapier Exp $
+
+EAPI="2"
+
+AUTOTOOLS_AUTO_DEPEND="no"
+inherit eutils flag-o-matic multilib autotools
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://source.winehq.org/git/wine.git"
+ inherit git
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ MY_P="${PN}-${PV/_/-}"
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+ KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd"
+ S=${WORKDIR}/${MY_P}
+fi
+
+pulse_patches() { echo "$1"/winepulse-{0.36,0.35-configure.ac,0.34-winecfg}.patch ; }
+GV="1.0.0-x86"
+DESCRIPTION="free implementation of Windows(tm) on Unix"
+HOMEPAGE="http://www.winehq.org/"
+SRC_URI="${SRC_URI}
+ gecko? ( mirror://sourceforge/wine/wine_gecko-${GV}.cab )
+ pulseaudio? ( `pulse_patches http://art.ified.ca/downloads/winepulse` )"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="alsa capi cups custom-cflags dbus esd fontconfig +gecko gnutls gphoto2 gsm hal jack jpeg lcms ldap mp3 nas ncurses openal +opengl oss +perl png pulseaudio samba scanner ssl test +threads +truetype win64 +X xcomposite xinerama xml"
+RESTRICT="test" #72375
+
+RDEPEND="truetype? ( >=media-libs/freetype-2.0.0 media-fonts/corefonts )
+ perl? ( dev-lang/perl dev-perl/XML-Simple )
+ capi? ( net-dialup/capi4k-utils )
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ fontconfig? ( media-libs/fontconfig )
+ gphoto2? ( media-libs/libgphoto2 )
+ jack? ( media-sound/jack-audio-connection-kit )
+ openal? ( media-libs/openal )
+ dbus? ( sys-apps/dbus )
+ gnutls? ( net-libs/gnutls )
+ hal? ( sys-apps/hal )
+ X? (
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXxf86vm
+ x11-apps/xmessage
+ )
+ xinerama? ( x11-libs/libXinerama )
+ alsa? ( media-libs/alsa-lib )
+ esd? ( media-sound/esound )
+ nas? ( media-libs/nas )
+ cups? ( net-print/cups )
+ opengl? ( virtual/opengl )
+ pulseaudio? ( media-sound/pulseaudio ${AUTOTOOLS_DEPEND} )
+ gsm? ( media-sound/gsm )
+ jpeg? ( media-libs/jpeg )
+ ldap? ( net-nds/openldap )
+ lcms? ( media-libs/lcms )
+ mp3? ( >=media-sound/mpg123-1.5.0 )
+ samba? ( >=net-fs/samba-3.0.25 )
+ xml? ( dev-libs/libxml2 dev-libs/libxslt )
+ scanner? ( media-gfx/sane-backends )
+ ssl? ( dev-libs/openssl )
+ png? ( media-libs/libpng )
+ !win64? ( amd64? (
+ truetype? ( >=app-emulation/emul-linux-x86-xlibs-2.1 )
+ X? (
+ >=app-emulation/emul-linux-x86-xlibs-2.1
+ >=app-emulation/emul-linux-x86-soundlibs-2.1
+ )
+ openal? ( app-emulation/emul-linux-x86-sdl )
+ app-emulation/emul-linux-x86-baselibs
+ >=sys-kernel/linux-headers-2.6
+ ) )
+ xcomposite? ( x11-libs/libXcomposite ) "
+DEPEND="${RDEPEND}
+ X? (
+ x11-proto/inputproto
+ x11-proto/xextproto
+ x11-proto/xf86vidmodeproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ sys-devel/bison
+ sys-devel/flex"
+
+src_unpack() {
+ if [[ $(( $(gcc-major-version) * 100 + $(gcc-minor-version) )) -lt 404 ]] ; then
+ use win64 && die "you need gcc-4.4+ to build 64bit wine"
+ fi
+
+ if [[ ${PV} == "9999" ]] ; then
+ git_src_unpack
+ else
+ unpack ${MY_P}.tar.bz2
+ fi
+}
+
+src_prepare() {
+ if use pulseaudio ; then
+ EPATCH_OPTS=-p1 epatch `pulse_patches "${DISTDIR}"`
+ eautoreconf
+ fi
+ epatch "${FILESDIR}"/${PN}-1.1.15-winegcc.patch #260726
+ epatch_user #282735
+ sed -i '/^UPDATE_DESKTOP_DATABASE/s:=.*:=true:' tools/Makefile.in || die
+ sed -i '/^MimeType/d' tools/wine.desktop || die #117785
+}
+
+src_configure() {
+ export LDCONFIG=/bin/true
+
+ use custom-cflags || strip-flags
+ use amd64 && ! use win64 && multilib_toolchain_setup x86
+
+ econf \
+ --sysconfdir=/etc/wine \
+ $(use_with alsa) \
+ $(use_with capi) \
+ $(use_with lcms cms) \
+ $(use_with cups) \
+ $(use_with ncurses curses) \
+ $(use_with esd) \
+ $(use_with fontconfig) \
+ $(use_with gnutls) \
+ $(use_with gphoto2 gphoto) \
+ $(use_with gsm) \
+ $(! use dbus && echo --without-hal || use_with hal) \
+ $(use_with jack) \
+ $(use_with jpeg) \
+ $(use_with ldap) \
+ $(use_with mp3 mpg123) \
+ $(use_with nas) \
+ $(use_with openal) \
+ $(use_with opengl) \
+ $(use_with ssl openssl) \
+ $(use_with oss) \
+ $(use_with png) \
+ $(use_with threads pthread) \
+ $(use_with pulseaudio pulse) \
+ $(use_with scanner sane) \
+ $(use_enable test tests) \
+ $(use_with truetype freetype) \
+ $(use_enable win64) \
+ $(use_with X x) \
+ $(use_with xcomposite) \
+ $(use_with xinerama) \
+ $(use_with xml) \
+ $(use_with xml xslt) \
+ || die "configure failed"
+
+ emake -j1 depend || die "depend"
+}
+
+src_compile() {
+ emake all || die "all"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ANNOUNCE AUTHORS README
+ if use gecko ; then
+ insinto /usr/share/wine/gecko
+ doins "${DISTDIR}"/wine_gecko-${GV}.cab || die
+ fi
+ if ! use perl ; then
+ rm "${D}"/usr/bin/{wine{dump,maker},function_grep.pl} "${D}"/usr/share/man/man1/wine{dump,maker}.1 || die
+ fi
+}
+
+pkg_postinst() {
+ paxctl -psmr "${ROOT}"/usr/bin/wine{,-preloader} 2>/dev/null #255055
+}