summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIskren Slavov <iskren.s@gmail.com>2011-01-06 17:57:52 +0200
committerIskren Slavov <iskren.s@gmail.com>2011-01-06 17:57:52 +0200
commitdd0d7d12515389c0abb996e9227f768d3006d4fe (patch)
tree59058b4e3aea4636fd187d38988ddb115af2c828 /dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild
parentAdded gambas, system-config-users (and it's dependencies) (diff)
downloadwish-dd0d7d12515389c0abb996e9227f768d3006d4fe.tar.gz
wish-dd0d7d12515389c0abb996e9227f768d3006d4fe.tar.bz2
wish-dd0d7d12515389c0abb996e9227f768d3006d4fe.zip
backintime-1.0.6 update, ossp-uuid cleaned up ebuild, gnome-themes-ementary
Diffstat (limited to 'dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild')
-rw-r--r--dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild b/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild
new file mode 100644
index 0000000..80ea0bf
--- /dev/null
+++ b/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ossp-uuid/ossp-uuid-1.6.2.ebuild,v 1.8 2010/04/25 20:14:06 armin76 Exp $
+
+EAPI="1"
+
+inherit eutils multilib
+MY_P="uuid-${PV}"
+
+DESCRIPTION="An ISO-C:1999 API and corresponding CLI for the generation of DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant UUID."
+HOMEPAGE="http://www.ossp.org/pkg/lib/uuid/"
+SRC_URI="ftp://ftp.ossp.org/pkg/lib/uuid/${MY_P}.tar.gz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="+cxx"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+}
+
+src_compile() {
+ # Notes:
+ # * collides with e2fstools libs and includes if not moved around
+ # * perl-bindings are broken
+ # * pgsql-bindings need PostgreSQL-sources and are included since PostgreSQL 8.3
+ econf \
+ --includedir=/usr/include/ossp \
+ --with-dce \
+ --without-pgsql \
+ --without-perl \
+ --without-php \
+ $(use_with cxx) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BINDINGS ChangeLog HISTORY NEWS OVERVIEW PORTING README SEEALSO THANKS TODO USERS
+
+ mv "${D}/usr/$(get_libdir)/pkgconfig"/{,ossp-}uuid.pc
+ mv "${D}/usr/share/man/man3"/uuid.3{,ossp}
+ mv "${D}/usr/share/man/man3"/uuid++.3{,ossp}
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ # Tests for the php-bindings would be available
+}