summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Kuhn <Wuodan0@gmail.com>2014-12-25 15:55:07 +0100
committerStefan Kuhn <Wuodan0@gmail.com>2014-12-25 15:57:17 +0100
commit2452bb04be5e92611c09955811ae90ff5299ab7a (patch)
tree3e91d52e8c2a813f73d3410eda56cb67dee979a3
parentapp-misc/tty-clock: version bumps. v0.1 declared stable (diff)
downloadwuodan-2452bb04be5e92611c09955811ae90ff5299ab7a.tar.gz
wuodan-2452bb04be5e92611c09955811ae90ff5299ab7a.tar.bz2
wuodan-2452bb04be5e92611c09955811ae90ff5299ab7a.zip
pentoo/pentoo-installer: ebuild for my reworked version of the installer
-rw-r--r--pentoo/pentoo-installer/Manifest2
-rw-r--r--pentoo/pentoo-installer/files/pentoo-installer.desktop11
-rw-r--r--pentoo/pentoo-installer/pentoo-installer-99999999.ebuild39
-rw-r--r--profiles/categories1
4 files changed, 53 insertions, 0 deletions
diff --git a/pentoo/pentoo-installer/Manifest b/pentoo/pentoo-installer/Manifest
new file mode 100644
index 0000000..3a5f505
--- /dev/null
+++ b/pentoo/pentoo-installer/Manifest
@@ -0,0 +1,2 @@
+AUX pentoo-installer.desktop 214 SHA256 bd7796fe3d6c998c033dd63bcfb81a0ecd0980b8d736d85af45c3604f191aef3 SHA512 8d509a55653efba02e6c398c728f2cf49e7ee6d56510fc0dddab5db9026b7f3dbbaebbe10537040a3b6d8cfecdda7aa282bd90ebe5c4c42aedfa1bb8e282cdae WHIRLPOOL 042817cd99601a7137fb0ae1dbbac9f23370a066eff73bd1b3aeaac767644b6c387b089801b994fed6d72b5130228cb40ee99717ee4a2b3c4175c8f7acff9efa
+EBUILD pentoo-installer-99999999.ebuild 881 SHA256 c8470893d3e7edb7197c504a7e3d8357c02e5c61a6a028a8fc7bd186cd0f491a SHA512 1a39a1a5e245976164da1e5ca964d095d1009386b47eaf6b94feb374a8a876065e969d58ac8522ca63e8c5ddef6d42418c72c873fd5b0ab31fb0b28f282ac60b WHIRLPOOL 206c4af15a1b27811fa5d93ca87adbbfd9b97f3b22956cd1d5e0503ad649bf5d3d864d18fa06d445bd6b33f0729a3761c67aa36ca2655c3a3c7b34cef69e363f
diff --git a/pentoo/pentoo-installer/files/pentoo-installer.desktop b/pentoo/pentoo-installer/files/pentoo-installer.desktop
new file mode 100644
index 0000000..990c97c
--- /dev/null
+++ b/pentoo/pentoo-installer/files/pentoo-installer.desktop
@@ -0,0 +1,11 @@
+
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=pentoo-installer
+Comment=Install Pentoo!
+Exec=/usr/sbin/pentoo-installer
+Icon=/usr/share/genmenu/pixmaps/pentoo.png
+Path=/root/
+Terminal=false
+StartupNotify=false
diff --git a/pentoo/pentoo-installer/pentoo-installer-99999999.ebuild b/pentoo/pentoo-installer/pentoo-installer-99999999.ebuild
new file mode 100644
index 0000000..ca57a0f
--- /dev/null
+++ b/pentoo/pentoo-installer/pentoo-installer-99999999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit subversion
+
+DESCRIPTION="Installer for pentoo, based on the ncurses Arch Linux installer"
+HOMEPAGE="https://code.google.com/p/pentoo/"
+# ESVN_REPO_URI="https://pentoo.googlecode.com/svn/${PN}/trunk"
+ESVN_REPO_URI="https://${PN}.googlecode.com/svn/trunk"
+
+LICENSE="GPL-3"
+SLOT="0"
+if [[ "${PV}" == "99999999" ]] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="amd64 x86"
+ ESVN_REVISION="head"
+fi
+
+IUSE="X"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="dev-util/dialog
+ X? ( x11-misc/xdialog )
+ || ( sys-boot/grub:0
+ sys-boot/grub-static:0 )
+ sys-boot/grub:2
+ sys-fs/squashfs-tools
+ net-misc/rsync"
+
+src_install() {
+ dodir /usr/
+ cp -R "${S}"/* "${ED}"/usr/ || die "Copy files failed"
+ exeinto /root/Desktop/
+ doexe share/applications/pentoo-installer.desktop
+}
diff --git a/profiles/categories b/profiles/categories
new file mode 100644
index 0000000..53bcc8c
--- /dev/null
+++ b/profiles/categories
@@ -0,0 +1 @@
+pentoo