summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-firmware/edk2/edk2-9999-r11337.ebuild')
-rw-r--r--sys-firmware/edk2/edk2-9999-r11337.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/sys-firmware/edk2/edk2-9999-r11337.ebuild b/sys-firmware/edk2/edk2-9999-r11337.ebuild
index e991c48..cc4cdd4 100644
--- a/sys-firmware/edk2/edk2-9999-r11337.ebuild
+++ b/sys-firmware/edk2/edk2-9999-r11337.ebuild
@@ -19,19 +19,19 @@ ESVN_REPO_URI="http://edk2.svn.sourceforge.net/svnroot/edk2/trunk/edk2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="hello-world kvm shell"
-REQUIRED_USE="|| ( hello-world kvm shell )"
+IUSE="hello-world qemu shell"
+REQUIRED_USE="|| ( hello-world qemu shell )"
DEPEND="
app-arch/unzip
sys-devel/binutils
sys-libs/glibc
>=dev-vcs/subversion-1.5
- kvm? (
+ qemu? (
>=app-emulation/qemu-0.9.1
sys-power/iasl
)"
-RDEPEND="kvm? ( >=app-emulation/qemu-0.9.1 )"
+RDEPEND="qemu? ( >=app-emulation/qemu-0.9.1 )"
S="$(dirname ${S})"
@@ -54,7 +54,7 @@ src_unpack(){
MdePkg
MdeModulePkg
"
- use kvm && repo_pkg+="
+ use qemu && repo_pkg+="
OvmfPkg
OptionRomPkg
UefiCpuPkg
@@ -64,7 +64,7 @@ src_unpack(){
EdkShellBinPkg
IntelFrameworkPkg
"
- ( use kvm || use shell ) && repo_pkg+="
+ ( use qemu || use shell ) && repo_pkg+="
ShellPkg
"
einfo "### Be patient! ###"
@@ -106,7 +106,7 @@ src_prepare(){
-e "s/^(CXX *= *).*$/\1`echo "${CFLAGS}"`/" \
"BaseTools/Source/C/VfrCompile/Pccts/${file}" || die "Failed to patch compiler flags in ${file}"
done
- # filter our -march, building for kvm guest!
+ # filter our -march, building for qemu guest!
filter-flags -march*
sed -i -r \
-e "s/gcc[[:space:]]*$/`tc-getCC`/" \
@@ -137,12 +137,12 @@ src_compile(){
build --arch "${ARCH}" --platform MdeModulePkg/MdeModulePkg.dsc --tagname "${TAGNAME}" \
--module MdeModulePkg/Application/HelloWorld/HelloWorld.inf \
--buildtarget RELEASE || die "Failed to build HelloWorld"
- # create startup.nsh for kvm testing
+ # create startup.nsh for qemu testing
echo "fs0:\HelloWorld.efi" > Build/MdeModule/RELEASE_GCC45/X64/startup.nsh || die "Failed to
create startup.nsh"
fi
- if use kvm; then
+ if use qemu; then
build --arch "${ARCH}" --platform OvmfPkg/OvmfPkgX64.dsc --tagname "${TAGNAME}" \
--buildtarget RELEASE || die "Failed to build UEFI-shell"
fi
@@ -164,11 +164,11 @@ src_install(){
doins "Build/MdeModule/RELEASE_${TAGNAME}/X64/startup.nsh"
fi
- if use kvm; then
- insinto "/usr/share/${PN}/kvm"
+ if use qemu; then
+ insinto "/usr/share/${PN}/qemu"
newins Build/OvmfX64/RELEASE_GCC45/FV/OVMF.fd uefibios.bin
newins Build/OvmfX64/RELEASE_GCC45/FV/CirrusLogic5446.rom vgabios-cirrus.bin
- dosym "../${PN}/kvm/uefibios.bin" /usr/share/qemu/uefibios.bin
+ dosym "../${PN}/qemu/uefibios.bin" /usr/share/qemu/uefibios.bin
fi
if use shell; then
@@ -178,11 +178,11 @@ src_install(){
}
pkg_postinst() {
- use kvm && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
+ use qemu && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
if use hello-world; then
einfo "A sample HelloWorld.efi was installed in /usr/share/${PN}/hello-world."
- if use kvm; then
- einfo "To test the uefi support in kvm, simply run:"
+ if use qemu; then
+ einfo "To test the uefi support in qemu, simply run:"
einfo " qemu-kvm -hda fat:/usr/share/${PN}/hello-world -bios uefibios.bin"
einfo "and await the message 'UEFI Hello World!' before the shell prompt appears."
fi