summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:34:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-04-07 19:34:25 +0000
commit0de2b4b506b1076a82c46d7a25e38b44e0daa788 (patch)
tree394cc195c39e9fdd1aab6cf855d1f2ff9b799ed4
parentUse EAPI5 instead of EAPI1. (diff)
downloadgentoo-2-0de2b4b506b1076a82c46d7a25e38b44e0daa788.tar.gz
gentoo-2-0de2b4b506b1076a82c46d7a25e38b44e0daa788.tar.bz2
gentoo-2-0de2b4b506b1076a82c46d7a25e38b44e0daa788.zip
Use EAPI5 instead of EAPI1.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
-rw-r--r--x11-plugins/bfm/ChangeLog7
-rw-r--r--x11-plugins/bfm/bfm-0.6.4-r1.ebuild24
2 files changed, 16 insertions, 15 deletions
diff --git a/x11-plugins/bfm/ChangeLog b/x11-plugins/bfm/ChangeLog
index 69ed5f04260f..1a7b5ad3607a 100644
--- a/x11-plugins/bfm/ChangeLog
+++ b/x11-plugins/bfm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-plugins/bfm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/bfm/ChangeLog,v 1.16 2012/05/05 05:12:01 jdhore Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/bfm/ChangeLog,v 1.17 2014/04/07 19:34:25 ssuominen Exp $
+
+ 07 Apr 2014; Samuli Suominen <ssuominen@gentoo.org> bfm-0.6.4-r1.ebuild:
+ Use EAPI5 instead of EAPI1.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> bfm-0.6.4-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/x11-plugins/bfm/bfm-0.6.4-r1.ebuild b/x11-plugins/bfm/bfm-0.6.4-r1.ebuild
index 2cf6cf27a615..9bfacaf144e1 100644
--- a/x11-plugins/bfm/bfm-0.6.4-r1.ebuild
+++ b/x11-plugins/bfm/bfm-0.6.4-r1.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/bfm/bfm-0.6.4-r1.ebuild,v 1.10 2012/05/05 05:12:01 jdhore Exp $
-
-EAPI="1"
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/bfm/bfm-0.6.4-r1.ebuild,v 1.11 2014/04/07 19:34:25 ssuominen Exp $
+EAPI=5
inherit multilib toolchain-funcs
DESCRIPTION="a dockapp and gkrellm plug-in combining timecop's bubblemon and wmfishtime."
@@ -22,21 +21,20 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
gkrellm? ( >=app-admin/gkrellm-2 )"
-src_unpack() {
- unpack ${A}
- sed -e 's:CFLAGS =:CFLAGS +=:' -e 's:LDFLAGS =:LDFLAGS +=:' -e 's:strip:true:' \
+src_prepare() {
+ sed -i \
+ -e 's:CFLAGS =:CFLAGS +=:' \
+ -e 's:LDFLAGS =:LDFLAGS +=:' \
+ -e 's:strip:true:' \
-e 's:$(CFLAGS) -o $(BUBBLEFISHYMON):$(CFLAGS) $(SRCS) -o $(BUBBLEFISHYMON):' \
-e 's:$(LIBS) $(GTK2_LIBS) $(SRCS):$(LIBS) $(GTK2_LIBS):' \
-e 's:-o $(BUBBLEFISHYMON):$(GENTOO_LDFLAGS) -o $(BUBBLEFISHYMON):' \
- -i "${S}"/Makefile
+ Makefile || die
}
src_compile() {
- emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}" || die "emake failed."
-
- if use gkrellm; then
- emake gkrellm CC="$(tc-getCC)" || die "emake failed."
- fi
+ emake CC="$(tc-getCC)" GENTOO_LDFLAGS="${LDFLAGS}"
+ use gkrellm && emake gkrellm CC="$(tc-getCC)"
}
src_install() {