summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-08-26 05:05:14 +0000
committerTim Harder <radhermit@gentoo.org>2013-08-26 05:05:14 +0000
commit3504c182be1a4c2471ac58f4bc4c18fea6278826 (patch)
tree5a9521a7a2b6370a7c47382bd08becc2c4f61188
parentdev-haskell/punycode: initial layout (diff)
downloadgentoo-2-3504c182be1a4c2471ac58f4bc4c18fea6278826.tar.gz
gentoo-2-3504c182be1a4c2471ac58f4bc4c18fea6278826.tar.bz2
gentoo-2-3504c182be1a4c2471ac58f4bc4c18fea6278826.zip
Version bump (bug #482406).
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--dev-vcs/tig/ChangeLog7
-rw-r--r--dev-vcs/tig/tig-1.2.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-vcs/tig/ChangeLog b/dev-vcs/tig/ChangeLog
index df4e03301de4..4e9e8438e7e1 100644
--- a/dev-vcs/tig/ChangeLog
+++ b/dev-vcs/tig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/tig
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.22 2013/08/10 19:07:01 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/ChangeLog,v 1.23 2013/08/26 05:05:14 radhermit Exp $
+
+*tig-1.2.1 (26 Aug 2013)
+
+ 26 Aug 2013; Tim Harder <radhermit@gentoo.org> +tig-1.2.1.ebuild:
+ Version bump (bug #482406).
*tig-1.2 (10 Aug 2013)
diff --git a/dev-vcs/tig/tig-1.2.1.ebuild b/dev-vcs/tig/tig-1.2.1.ebuild
new file mode 100644
index 000000000000..5ecf19d503f8
--- /dev/null
+++ b/dev-vcs/tig/tig-1.2.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tig/tig-1.2.1.ebuild,v 1.1 2013/08/26 05:05:14 radhermit Exp $
+
+EAPI=5
+
+inherit bash-completion-r1 toolchain-funcs
+
+DESCRIPTION="Tig: text mode interface for git"
+HOMEPAGE="http://jonas.nitro.dk/tig/"
+SRC_URI="http://jonas.nitro.dk/tig/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+CDEPEND="sys-libs/ncurses"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ dev-vcs/git"
+
+src_prepare() {
+ # pre-generated manpages are in the root directory
+ sed -i '/^MANDOC/s#doc/##g' Makefile || die
+}
+
+src_configure() {
+ econf CURSES_LIB="$($(tc-getPKG_CONFIG) --libs ncursesw)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc BUGS NEWS
+ dohtml manual.html README.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+}