summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-23 20:18:45 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-23 20:18:45 +0000
commitcdc69693aa2a77e1d9ebcd95d8ee2c495f9c77d3 (patch)
tree5aa712afdbe35f936eab955c69373fa446234639 /app-admin/supervisor
parentDelete older ebuild. (diff)
downloadgentoo-2-cdc69693aa2a77e1d9ebcd95d8ee2c495f9c77d3.tar.gz
gentoo-2-cdc69693aa2a77e1d9ebcd95d8ee2c495f9c77d3.tar.bz2
gentoo-2-cdc69693aa2a77e1d9ebcd95d8ee2c495f9c77d3.zip
Version bump.
(Portage version: 2.2_rc86_p3/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/supervisor')
-rw-r--r--app-admin/supervisor/ChangeLog8
-rw-r--r--app-admin/supervisor/supervisor-3.0_alpha9.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/app-admin/supervisor/ChangeLog b/app-admin/supervisor/ChangeLog
index 5ae7c03c1050..8712a4901ec8 100644
--- a/app-admin/supervisor/ChangeLog
+++ b/app-admin/supervisor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/supervisor
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/ChangeLog,v 1.2 2010/06/07 10:23:47 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/ChangeLog,v 1.3 2010/09/23 20:18:45 arfrever Exp $
+
+*supervisor-3.0_alpha9 (23 Sep 2010)
+
+ 23 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -supervisor-3.0_alpha8.ebuild, +supervisor-3.0_alpha9.ebuild:
+ Version bump.
07 Jun 2010; Dirkjan Ochtman <djc@gentoo.org>
+files/3.0_alpha8-no-docs.patch, supervisor-3.0_alpha8.ebuild:
diff --git a/app-admin/supervisor/supervisor-3.0_alpha9.ebuild b/app-admin/supervisor/supervisor-3.0_alpha9.ebuild
new file mode 100644
index 000000000000..7fd133deb357
--- /dev/null
+++ b/app-admin/supervisor/supervisor-3.0_alpha9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/supervisor/supervisor-3.0_alpha9.ebuild,v 1.1 2010/09/23 20:18:45 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+PYTHON_USE_WITH="xml"
+SUPPORT_PYTHON_ABIS="1"
+# xml.etree.ElementTree module required.
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+DISTUTILS_SRC_TEST="setup.py"
+
+inherit distutils eutils
+
+MY_PV="${PV/_alpha/a}"
+
+DESCRIPTION="A system for controlling process state under UNIX"
+HOMEPAGE="http://supervisord.org/ http://pypi.python.org/pypi/supervisor"
+SRC_URI="http://dist.supervisord.org/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="repoze ZPL BSD as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/meld3
+ dev-python/setuptools"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock )"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DOCS="CHANGES.txt README.txt TODO.txt"
+
+src_prepare() {
+ distutils_src_prepare
+ epatch "${FILESDIR}/3.0_alpha8-no-docs.patch"
+}
+
+src_install() {
+ distutils_src_install
+ newinitd "${FILESDIR}/init.d" supervisord
+ newconfd "${FILESDIR}/conf.d" supervisord
+}