summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-05-07 15:29:03 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-05-07 15:29:03 +0000
commitba9eff2eb5f58832f79b8c253778abb3149bdd36 (patch)
treec7be73be9685290f1b1d170e9666273efdeed709 /app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild
parentChainsaw is taking over maintaining nvidia-drivers (diff)
downloadgentoo-2-ba9eff2eb5f58832f79b8c253778abb3149bdd36.tar.gz
gentoo-2-ba9eff2eb5f58832f79b8c253778abb3149bdd36.tar.bz2
gentoo-2-ba9eff2eb5f58832f79b8c253778abb3149bdd36.zip
Fixed build failure with gcc-4.3, the patch is from debian bug #455270.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild')
-rw-r--r--app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild b/app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild
new file mode 100644
index 000000000000..924479402271
--- /dev/null
+++ b/app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-skk/scim-skk-0.5.2-r1.ebuild,v 1.1 2008/05/07 15:29:02 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Japanese input method SKK IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMSKK"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/18121/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+DEPEND="|| ( >=app-i18n/scim-1.2 >=app-i18n/scim-cvs-1.2 )"
+RDEPEND="${DEPEND}
+ || ( app-i18n/skk-jisyo virtual/skkserv )
+ nls? ( virtual/libintl )"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ --disable-dependency-tracking \
+ --disable-static || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+}
+
+pkg_postinst() {
+ elog
+ elog "To use SCIM, you should use the following in your user startup scripts"
+ elog "such as .gnomerc or .xinitrc:"
+ elog
+ elog "LANG='your_language' scim -d"
+ elog "export XMODIFIERS=@im=SCIM"
+ elog "export GTK_IM_MODULE=scim"
+ elog "export QT_IM_MODULE=scim"
+ elog
+}