summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-01 19:59:06 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-08-01 19:59:06 +0000
commit650c318d8ae96ad8ec0d9d9ea0eacba6de7b2320 (patch)
tree63a2fafc535b9de5ea1a3d4e081c018ab9532d42 /app-shells/bash/bash-3.1_p17.ebuild
parentMove back to ~x86, since this version doesn't work on 2.6.x kernels. See bug ... (diff)
downloadgentoo-2-650c318d8ae96ad8ec0d9d9ea0eacba6de7b2320.tar.gz
gentoo-2-650c318d8ae96ad8ec0d9d9ea0eacba6de7b2320.tar.bz2
gentoo-2-650c318d8ae96ad8ec0d9d9ea0eacba6de7b2320.zip
Don't make the ls alias when not using GNU userland, or it will break; export CLICOLOR for Gentoo/FreeBSD compatibility.
(Portage version: 2.1.1_pre4-r1)
Diffstat (limited to 'app-shells/bash/bash-3.1_p17.ebuild')
-rw-r--r--app-shells/bash/bash-3.1_p17.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-shells/bash/bash-3.1_p17.ebuild b/app-shells/bash/bash-3.1_p17.ebuild
index bfaf2e1655cd..792a2de6859c 100644
--- a/app-shells/bash/bash-3.1_p17.ebuild
+++ b/app-shells/bash/bash-3.1_p17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.2 2006/05/06 00:58:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash/bash-3.1_p17.ebuild,v 1.3 2006/08/01 19:59:06 flameeyes Exp $
inherit eutils flag-o-matic toolchain-funcs
@@ -108,7 +108,7 @@ src_compile() {
--disable-profiling \
--without-gnu-malloc \
${myconf} || die
- emake -j1 || die "make failed" # see bug 102426
+ emake -j1 || die "make failed" # see bug 102426
}
src_install() {
@@ -126,6 +126,10 @@ src_install() {
newins "${FILESDIR}"/dot-${f} .${f}
done
+ if use userland_GNU; then
+ sed -i -e 's:^#GNU#::' "${D}/etc/skel/.bashrc"
+ fi
+
if use build ; then
rm -rf "${D}"/usr
else
@@ -141,7 +145,7 @@ pkg_preinst() {
mv -f "${ROOT}"/etc/bashrc "${ROOT}"/etc/bash/
fi
- # our bash_logout is just a place holder so dont
+ # our bash_logout is just a place holder so dont
# force users to go through etc-update all the time
if [[ -e ${ROOT}/etc/bash/bash_logout ]] ; then
rm -f "${D}"/etc/bash/bash_logout