summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-29 03:54:48 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-29 03:54:48 +0000
commit8ed3528a34c4250c5e07eb46696ef894cad51e40 (patch)
tree05eb75b54c7dd4f2159c22987736133e41a56d94 /app-shells/esh
parentversion bump (Bug 33995) and java fix (Manifest recommit) (diff)
downloadgentoo-2-8ed3528a34c4250c5e07eb46696ef894cad51e40.tar.gz
gentoo-2-8ed3528a34c4250c5e07eb46696ef894cad51e40.tar.bz2
gentoo-2-8ed3528a34c4250c5e07eb46696ef894cad51e40.zip
change virtual/glibc to virtual/libc
Diffstat (limited to 'app-shells/esh')
-rw-r--r--app-shells/esh/esh-0.8-r2.ebuild32
-rw-r--r--app-shells/esh/esh-0.8.5.ebuild31
2 files changed, 31 insertions, 32 deletions
diff --git a/app-shells/esh/esh-0.8-r2.ebuild b/app-shells/esh/esh-0.8-r2.ebuild
index 9f446b7a1c97..a0eee00acaa6 100644
--- a/app-shells/esh/esh-0.8-r2.ebuild
+++ b/app-shells/esh/esh-0.8-r2.ebuild
@@ -1,33 +1,33 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r2.ebuild,v 1.15 2004/06/24 22:24:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r2.ebuild,v 1.16 2004/06/29 03:54:48 vapier Exp $
-S=${WORKDIR}/esh
DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
-SRC_URI="http://esh.netpedia.net/${P}.tar.gz"
HOMEPAGE="http://esh.netpedia.net/"
-KEYWORDS="x86 sparc"
-SLOT="0"
+SRC_URI="http://esh.netpedia.net/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc"
+IUSE=""
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
- >=sys-libs/readline-4.1"
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1"
-src_compile() {
+S=${WORKDIR}/${PN}
- cp Makefile Makefile.orig
- sed -e "s:^CFLAGS=:CFLAGS=${CFLAGS/-fomit-frame-pointer/} :" \
- -e "s:^LIB=:LIB=-lncurses :" Makefile.orig > Makefile
+src_compile() {
+ sed -i \
+ -e "s:^CFLAGS=:CFLAGS=${CFLAGS/-fomit-frame-pointer/} :" \
+ -e "s:^LIB=:LIB=-lncurses :" Makefile
make || die
}
src_install() {
-
- dobin esh
- into /usr
+ dobin esh || die
doinfo doc/esh.info
- dodoc CHANGELOG CREDITS GC_README HEADER LICENSE READLNE-HACKS TODO
+ dodoc CHANGELOG CREDITS GC_README HEADER READLNE-HACKS TODO
docinto html
dodoc doc/*.html
docinto examples
diff --git a/app-shells/esh/esh-0.8.5.ebuild b/app-shells/esh/esh-0.8.5.ebuild
index 5b77bb2489d6..9b20c99a0118 100644
--- a/app-shells/esh/esh-0.8.5.ebuild
+++ b/app-shells/esh/esh-0.8.5.ebuild
@@ -1,27 +1,28 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5.ebuild,v 1.12 2004/06/24 22:24:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8.5.ebuild,v 1.13 2004/06/29 03:54:48 vapier Exp $
-S=${WORKDIR}/esh
DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
-SRC_URI="http://slon.ttk.ru/esh/${P}.tar.gz"
HOMEPAGE="http://slon.ttk.ru/esh/"
-KEYWORDS="x86 -ppc sparc"
-SLOT="0"
+SRC_URI="http://slon.ttk.ru/esh/${P}.tar.gz"
+
LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc sparc"
+IUSE=""
-DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.1
- >=sys-libs/readline-4.1"
+DEPEND="virtual/libc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/readline-4.1"
+S=${WORKDIR}/${PN}
src_compile() {
-
- cp Makefile Makefile.orig
- sed -e "s:^CFLAGS=:CFLAGS=${CFLAGS/-fomit-frame-pointer/} :" \
+ sed -i \
+ -e "s:^CFLAGS=:CFLAGS=${CFLAGS/-fomit-frame-pointer/} :" \
-e "s:^LIB=:LIB=-lncurses :" \
-e "s:-ltermcap::" \
- Makefile.orig > Makefile
+ Makefile
# For some reason, this tarball has binary files in it for x86.
# Make clean so we can rebuild for our arch and optimization.
make clean
@@ -29,11 +30,9 @@ src_compile() {
}
src_install() {
-
- dobin esh
- into /usr
+ dobin esh || die
doinfo doc/esh.info
- dodoc CHANGELOG CREDITS GC_README HEADER LICENSE READLNE-HACKS TODO
+ dodoc CHANGELOG CREDITS GC_README HEADER READLNE-HACKS TODO
dohtml doc/*.html
docinto examples
dodoc examples/*