summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-25 18:28:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-25 18:28:14 +0000
commit13fd95dba50ef35b8570dec32c5f1eda545fd53e (patch)
treeac8090d32a8e28d922d3ae627c43424aa6789bfc /dev-libs/boost/boost-1.35.0-r2.ebuild
parentDelete older ebuild. (diff)
downloadgentoo-2-13fd95dba50ef35b8570dec32c5f1eda545fd53e.tar.gz
gentoo-2-13fd95dba50ef35b8570dec32c5f1eda545fd53e.tar.bz2
gentoo-2-13fd95dba50ef35b8570dec32c5f1eda545fd53e.zip
Delete calls to deprecated python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/boost/boost-1.35.0-r2.ebuild')
-rw-r--r--dev-libs/boost/boost-1.35.0-r2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-libs/boost/boost-1.35.0-r2.ebuild b/dev-libs/boost/boost-1.35.0-r2.ebuild
index f52e05d9168c..645c77bfe996 100644
--- a/dev-libs/boost/boost-1.35.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.35.0-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.14 2009/10/21 16:57:23 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.35.0-r2.ebuild,v 1.15 2010/04/25 18:28:14 arfrever Exp $
inherit python flag-o-matic multilib toolchain-funcs versionator check-reqs
@@ -94,7 +94,6 @@ generate_options() {
generate_userconfig() {
einfo "Writing new user-config.jam"
- python_version
local compiler compilerVersion compilerExecutable
if [[ ${CHOST} == *-darwin* ]] ; then
@@ -114,7 +113,7 @@ variant gentoorelease : release : <optimization>none <debug-symbols>none ;
variant gentoodebug : debug : <optimization>none <debug-symbols>none ;
using ${compiler} : ${compilerVersion} : ${compilerExecutable} : <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
-using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;
+using python : $(python_get_version) : /usr : $(python_get_includedir) : $(python_get_libdir) ;
__EOF__
@@ -171,8 +170,8 @@ src_install () {
# Move the mpi.so to the right place
if use mpi; then
- mkdir -p "${D}/usr/$(get_libdir)/python${PYVER}/site-packages"
- mv "${D}/usr/$(get_libdir)/mpi.so" "${D}/usr/$(get_libdir)/python${PYVER}/site-packages"
+ mkdir -p "${D}$(python_get_sitedir)"
+ mv "${D}/usr/$(get_libdir)/mpi.so" "${D}$(python_get_sitedir)"
fi
if use doc ; then