summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-01-17 14:03:07 +0000
committerTim Harder <radhermit@gentoo.org>2015-01-17 14:03:07 +0000
commitc059b814bf6c6c9854ce8fcfafbf8461130b5c97 (patch)
tree4e988e2dfb3f939bc751d054d8a3974784cd3110 /dev-python/graph-tool
parentStable for ppc, wrt bug #534812 (diff)
downloadgentoo-2-c059b814bf6c6c9854ce8fcfafbf8461130b5c97.tar.gz
gentoo-2-c059b814bf6c6c9854ce8fcfafbf8461130b5c97.tar.bz2
gentoo-2-c059b814bf6c6c9854ce8fcfafbf8461130b5c97.zip
Run eautoreconf and update git repo for live ebuild (bugs #536810 and 536826).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/graph-tool')
-rw-r--r--dev-python/graph-tool/ChangeLog7
-rw-r--r--dev-python/graph-tool/graph-tool-2.2.36.ebuild16
-rw-r--r--dev-python/graph-tool/graph-tool-9999.ebuild17
3 files changed, 23 insertions, 17 deletions
diff --git a/dev-python/graph-tool/ChangeLog b/dev-python/graph-tool/ChangeLog
index 2ab0c83fac7a..ef5e0e19b329 100644
--- a/dev-python/graph-tool/ChangeLog
+++ b/dev-python/graph-tool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/graph-tool
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/ChangeLog,v 1.20 2015/01/14 03:43:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/ChangeLog,v 1.21 2015/01/17 14:03:07 radhermit Exp $
+
+ 17 Jan 2015; Tim Harder <radhermit@gentoo.org> graph-tool-2.2.36.ebuild,
+ graph-tool-9999.ebuild:
+ Run eautoreconf and update git repo for live ebuild (bugs #536810 and
+ 536826).
*graph-tool-2.2.36 (14 Jan 2015)
diff --git a/dev-python/graph-tool/graph-tool-2.2.36.ebuild b/dev-python/graph-tool/graph-tool-2.2.36.ebuild
index 6537038d64d1..70a6977a22ab 100644
--- a/dev-python/graph-tool/graph-tool-2.2.36.ebuild
+++ b/dev-python/graph-tool/graph-tool-2.2.36.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-2.2.36.ebuild,v 1.1 2015/01/14 03:43:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-2.2.36.ebuild,v 1.2 2015/01/17 14:03:07 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -8,8 +8,8 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit check-reqs toolchain-funcs python-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.skewed.de/graph-tool"
- inherit git-2
+ EGIT_REPO_URI="https://github.com/count0/graph-tool.git"
+ inherit autotools git-r3
else
SRC_URI="http://downloads.skewed.de/${PN}/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
@@ -22,7 +22,6 @@ LICENSE="GPL-3"
SLOT="0"
IUSE="+cairo openmp"
-# Bug 524524
CDEPEND="${PYTHON_DEPS}
>=dev-libs/boost-1.54.0[python,${PYTHON_USEDEP}]
dev-libs/expat
@@ -46,19 +45,20 @@ MAKEOPTS="${MAKEOPTS} -j1"
CHECKREQS_DISK_BUILD="6G"
pkg_pretend() {
- if use openmp; then
+ if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible compiler"
fi
check-reqs_pkg_pretend
}
src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
>py-compile
python_copy_sources
}
src_configure() {
- python_parallel_foreach_impl run_in_build_dir \
+ python_foreach_impl run_in_build_dir \
econf \
--disable-static \
--disable-optimization \
@@ -67,11 +67,11 @@ src_configure() {
}
src_compile() {
- python_parallel_foreach_impl run_in_build_dir default
+ python_foreach_impl run_in_build_dir default
}
src_install() {
- python_parallel_foreach_impl run_in_build_dir default
+ python_foreach_impl run_in_build_dir default
prune_libtool_files --modules
# remove unwanted extra docs
diff --git a/dev-python/graph-tool/graph-tool-9999.ebuild b/dev-python/graph-tool/graph-tool-9999.ebuild
index 9086fa954808..9f020f3f47a4 100644
--- a/dev-python/graph-tool/graph-tool-9999.ebuild
+++ b/dev-python/graph-tool/graph-tool-9999.ebuild
@@ -1,15 +1,15 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-9999.ebuild,v 1.9 2015/01/14 03:43:42 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/graph-tool/graph-tool-9999.ebuild,v 1.10 2015/01/17 14:03:07 radhermit Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-inherit check-reqs eutils toolchain-funcs python-r1
+inherit check-reqs toolchain-funcs python-r1
if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="git://git.skewed.de/graph-tool"
- inherit git-2
+ EGIT_REPO_URI="https://github.com/count0/graph-tool.git"
+ inherit autotools git-r3
else
SRC_URI="http://downloads.skewed.de/${PN}/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
@@ -45,19 +45,20 @@ MAKEOPTS="${MAKEOPTS} -j1"
CHECKREQS_DISK_BUILD="6G"
pkg_pretend() {
- if use openmp; then
+ if use openmp ; then
tc-has-openmp || die "Please switch to an openmp compatible compiler"
fi
check-reqs_pkg_pretend
}
src_prepare() {
+ [[ ${PV} == "9999" ]] && eautoreconf
>py-compile
python_copy_sources
}
src_configure() {
- python_parallel_foreach_impl run_in_build_dir \
+ python_foreach_impl run_in_build_dir \
econf \
--disable-static \
--disable-optimization \
@@ -66,11 +67,11 @@ src_configure() {
}
src_compile() {
- python_parallel_foreach_impl run_in_build_dir default
+ python_foreach_impl run_in_build_dir default
}
src_install() {
- python_parallel_foreach_impl run_in_build_dir default
+ python_foreach_impl run_in_build_dir default
prune_libtool_files --modules
# remove unwanted extra docs