summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-28 07:05:15 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-28 07:05:15 +0000
commitb3be0a5d751caf4d10e483f25efc446c4b017459 (patch)
tree403b8446d5cffc9540aa1dcaa7fe96f55c1a835e /dev-python/pythondialog
parentVersion bump. (diff)
downloadgentoo-2-b3be0a5d751caf4d10e483f25efc446c4b017459.tar.gz
gentoo-2-b3be0a5d751caf4d10e483f25efc446c4b017459.tar.bz2
gentoo-2-b3be0a5d751caf4d10e483f25efc446c4b017459.zip
revbump, convert -> distutils-r1, bump, new version supports py3, fixes Bug #496524
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pythondialog')
-rw-r--r--dev-python/pythondialog/ChangeLog13
-rw-r--r--dev-python/pythondialog/pythondialog-2.7-r1.ebuild25
-rw-r--r--dev-python/pythondialog/pythondialog-3.0.1.ebuild20
3 files changed, 55 insertions, 3 deletions
diff --git a/dev-python/pythondialog/ChangeLog b/dev-python/pythondialog/ChangeLog
index 355215de1ec8..0888f50aafad 100644
--- a/dev-python/pythondialog/ChangeLog
+++ b/dev-python/pythondialog/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pythondialog
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/ChangeLog,v 1.17 2011/01/01 19:56:22 arfrever Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/ChangeLog,v 1.18 2014/03/28 07:05:15 idella4 Exp $
+
+*pythondialog-3.0.1 (28 Mar 2014)
+*pythondialog-2.7-r1 (28 Mar 2014)
+
+ 28 Mar 2014; Ian Delaney <idella4@gentoo.org> +pythondialog-2.7-r1.ebuild,
+ +pythondialog-3.0.1.ebuild:
+ revbump, convert -> distutils-r1, bump, new version supports py3, fixes Bug
+ #496524
01 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pythondialog-2.7.ebuild:
@@ -57,4 +65,3 @@
07 Feb 2003; Mark Guertin <gerk@gentoo.org> pythondialog-1.0.ebuild :
Initial build entry. Set as ~ for all arches, should work fine. Thanks
to Matt Tucker for the new ebuild, bug # 15238.
-
diff --git a/dev-python/pythondialog/pythondialog-2.7-r1.ebuild b/dev-python/pythondialog/pythondialog-2.7-r1.ebuild
new file mode 100644
index 000000000000..346c4d38d09f
--- /dev/null
+++ b/dev-python/pythondialog/pythondialog-2.7-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/pythondialog-2.7-r1.ebuild,v 1.1 2014/03/28 07:05:15 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module for making simple text/console-mode user interfaces."
+HOMEPAGE="http://pythondialog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pythondialog/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-util/dialog"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -e "/^prefix=/d" -i setup.cfg || die "sed failed"
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/pythondialog/pythondialog-3.0.1.ebuild b/dev-python/pythondialog/pythondialog-3.0.1.ebuild
new file mode 100644
index 000000000000..bbb6ee3e0107
--- /dev/null
+++ b/dev-python/pythondialog/pythondialog-3.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/pythondialog-3.0.1.ebuild,v 1.1 2014/03/28 07:05:15 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_2,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module for making simple text/console-mode user interfaces."
+HOMEPAGE="http://pythondialog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pythondialog//${PV}/python3-${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-util/dialog"
+RDEPEND="${DEPEND}"