summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2011-10-30 16:41:54 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2011-10-30 16:41:54 +0000
commit2c4356897c33450e664b4fce870f51ffd6bc412b (patch)
treead20ee739d83e2c3a92544f88438c654d4150ec5 /dev-python
parentAdd dev-python/assets-0.1.1, thanks to slepnoga (diff)
downloadgentoo-2-2c4356897c33450e664b4fce870f51ffd6bc412b.tar.gz
gentoo-2-2c4356897c33450e664b4fce870f51ffd6bc412b.tar.bz2
gentoo-2-2c4356897c33450e664b4fce870f51ffd6bc412b.zip
Add dev-python/wehjit-0.2.2, thanks to slepnoga. Bug #305887
(Portage version: 2.1.10.26/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wehjit/ChangeLog10
-rw-r--r--dev-python/wehjit/metadata.xml18
-rw-r--r--dev-python/wehjit/wehjit-0.2.2.ebuild31
3 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/wehjit/ChangeLog b/dev-python/wehjit/ChangeLog
new file mode 100644
index 000000000000..6eeb8cf98cac
--- /dev/null
+++ b/dev-python/wehjit/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/wehjit
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wehjit/ChangeLog,v 1.1 2011/10/30 16:41:54 maksbotan Exp $
+
+*wehjit-0.2.2 (30 Oct 2011)
+
+ 30 Oct 2011; Maxim Koltsov <maksbotan@gentoo.org> +wehjit-0.2.2.ebuild,
+ +metadata.xml:
+ Add dev-python/wehjit-0.2.2, thanks to slepnoga. Bug #305887
+
diff --git a/dev-python/wehjit/metadata.xml b/dev-python/wehjit/metadata.xml
new file mode 100644
index 000000000000..3e55cad8f8b1
--- /dev/null
+++ b/dev-python/wehjit/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<herd>python</herd>
+<maintainer>
+ <email>spamslepnoga@inbox.ru</email>
+</maintainer>
+<maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+</maintainer>
+<longdescription>
+ wehjit is a Python library for for building XHTML widgets for web
+ applications and web pages. It encapsulates the XHTML
+ (a Genshi XML template), CSS, and JavaScript for each widget into a plugin
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/wehjit/wehjit-0.2.2.ebuild b/dev-python/wehjit/wehjit-0.2.2.ebuild
new file mode 100644
index 000000000000..f241193252d8
--- /dev/null
+++ b/dev-python/wehjit/wehjit-0.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/wehjit/wehjit-0.2.2.ebuild,v 1.1 2011/10/30 16:41:54 maksbotan Exp $
+
+EAPI=3
+
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="A Python web-widget library"
+HOMEPAGE="http://jderose.fedorapeople.org/wehjit"
+SRC_URI="http://jderose.fedorapeople.org/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="dev-python/genshi
+ dev-python/assets
+ dev-python/paste
+ dev-python/pygments
+ "
+DEPEND="${RDEPEND}"
+
+DOCS="README TODO NEWS AUTHORS"
+
+python_enable_pyc