summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-07 13:40:30 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-07 13:40:30 +0000
commit367c9a38f40ee9f79283de8b20775b1df9f707bd (patch)
tree56388f31f2551d4356514e2d671d895a837071f4 /dev-tcltk/thread/thread-2.6.6.ebuild
parentQA (diff)
downloadgentoo-2-367c9a38f40ee9f79283de8b20775b1df9f707bd.tar.gz
gentoo-2-367c9a38f40ee9f79283de8b20775b1df9f707bd.tar.bz2
gentoo-2-367c9a38f40ee9f79283de8b20775b1df9f707bd.zip
Version Bump, which fixes the LDFLAGS repect, #335963
(Portage version: 2.2.0_alpha7/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/thread/thread-2.6.6.ebuild')
-rw-r--r--dev-tcltk/thread/thread-2.6.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-tcltk/thread/thread-2.6.6.ebuild b/dev-tcltk/thread/thread-2.6.6.ebuild
new file mode 100644
index 000000000000..38aac39f5daa
--- /dev/null
+++ b/dev-tcltk/thread/thread-2.6.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/thread/thread-2.6.6.ebuild,v 1.1 2010/12/07 13:40:28 jlec Exp $
+
+EAPI=2
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Tcl Thread extension"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gdbm"
+
+DEPEND="
+ dev-lang/tcl[threads]
+ gdbm? ( sys-libs/gdbm )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${PN}${PV}
+
+RESTRICT="test"
+
+src_prepare() {
+ # Search for libs in libdir not just exec_prefix/lib
+ sed -i -e 's:${exec_prefix}/lib:${libdir}:' \
+ aclocal.m4 || die "sed failed"
+
+ sed -i -e "s/relid'/relid/" tclconfig/tcl.m4
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-tclinclude=/usr/include \
+ --with-tcl="/usr/$(get_libdir)" \
+ $(use_with gdbm) \
+ $(use_enable debug symbols)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README || die
+}