summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-07-30 04:37:47 +0000
committerMike Frysinger <vapier@gentoo.org>2005-07-30 04:37:47 +0000
commit3eb719a3b8a13ef7af77b2aa214e520f3bb02eb5 (patch)
tree9ec60994bd0f60c636abd72eec676701c48fdd22 /games-action
parentinitial import (diff)
downloadgentoo-2-3eb719a3b8a13ef7af77b2aa214e520f3bb02eb5.tar.gz
gentoo-2-3eb719a3b8a13ef7af77b2aa214e520f3bb02eb5.tar.bz2
gentoo-2-3eb719a3b8a13ef7af77b2aa214e520f3bb02eb5.zip
Fix CFLAGS breakage and sync some mismatched prototypes.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/gltron/ChangeLog9
-rw-r--r--games-action/gltron/files/gltron-0.70-configure.patch24
-rw-r--r--games-action/gltron/files/gltron-0.70-prototypes.patch24
-rw-r--r--games-action/gltron/gltron-0.70.ebuild22
4 files changed, 75 insertions, 4 deletions
diff --git a/games-action/gltron/ChangeLog b/games-action/gltron/ChangeLog
index 997cd466745f..2c110af660d2 100644
--- a/games-action/gltron/ChangeLog
+++ b/games-action/gltron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-action/gltron
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.8 2005/05/31 16:16:32 cryos Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/ChangeLog,v 1.9 2005/07/30 04:37:47 vapier Exp $
+
+ 30 Jul 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/gltron-0.70-configure.patch, +files/gltron-0.70-prototypes.patch,
+ gltron-0.70.ebuild:
+ Fix CFLAGS breakage and sync some mismatched prototypes.
31 May 2005; Marcus D. Hanwell <marcus@gentoo.org> gltron-0.70.ebuild:
Stable on amd64.
diff --git a/games-action/gltron/files/gltron-0.70-configure.patch b/games-action/gltron/files/gltron-0.70-configure.patch
new file mode 100644
index 000000000000..91414b3956ec
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-configure.patch
@@ -0,0 +1,24 @@
+configure.in is written poorly so it just stomps all over CFLAGS
+
+--- configure
++++ configure
+@@ -2805,7 +2805,7 @@
+ RANLIB="$ac_cv_prog_RANLIB"
+ fi
+
+-CFLAGS="-DSEPARATOR=\"'/'\""
++CFLAGS="$CFLAGS -DSEPARATOR=\"'/'\""
+
+ # Check whether --enable-warn or --disable-warn was given.
+ if test "${enable_warn+set}" = set; then
+@@ -2852,10 +2852,6 @@
+ else
+ enable_optimize=s
+ fi;
+-if test "x$enable_optimize" ; then
+- CFLAGS="$CFLAGS -O$enable_optimize"
+- CXXFLAGS="$CXXFLAGS -O$enable_optimize"
+-fi
+
+ # Check whether --with-sdl-prefix or --without-sdl-prefix was given.
+ if test "${with_sdl_prefix+set}" = set; then
diff --git a/games-action/gltron/files/gltron-0.70-prototypes.patch b/games-action/gltron/files/gltron-0.70-prototypes.patch
new file mode 100644
index 000000000000..d697f1ad59ac
--- /dev/null
+++ b/games-action/gltron/files/gltron-0.70-prototypes.patch
@@ -0,0 +1,24 @@
+scripting.h declares these params as const so make sure they're the same.
+
+--- nebu/scripting/scripting.c
++++ nebu/scripting/scripting.c
+@@ -169,16 +169,16 @@
+ return status;
+ }
+
+-void scripting_RunFile(char *name) {
++void scripting_RunFile(const char *name) {
+ lua_dofile(L, name);
+ }
+
+-void scripting_Run(char *command) {
++void scripting_Run(const char *command) {
+ /* fprintf(stderr, "[command] %s\n", command); */
+ lua_dostring(L, command);
+ }
+
+-void scripting_RunFormat(char *format, ... ) {
++void scripting_RunFormat(const char *format, ... ) {
+ char buf[4096];
+ va_list ap;
+ va_start(ap, format);
diff --git a/games-action/gltron/gltron-0.70.ebuild b/games-action/gltron/gltron-0.70.ebuild
index 0daa48252401..c8ddae925921 100644
--- a/games-action/gltron/gltron-0.70.ebuild
+++ b/games-action/gltron/gltron-0.70.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70.ebuild,v 1.5 2005/05/31 16:16:32 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/gltron/gltron-0.70.ebuild,v 1.6 2005/07/30 04:37:47 vapier Exp $
-inherit games
+inherit eutils games
DESCRIPTION="3d tron, just like the movie"
HOMEPAGE="http://gltron.sourceforge.net/"
@@ -21,6 +21,24 @@ DEPEND="virtual/x11
media-libs/sdl-mixer
media-libs/sdl-sound"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure.patch
+ epatch "${FILESDIR}"/${P}-prototypes.patch
+}
+
+src_compile() {
+ # warn/debug/profile just modify CFLAGS, they aren't
+ # real options, so don't utilize USE flags here
+ egamesconf \
+ --disable-warn \
+ --disable-debug \
+ --disable-profile \
+ || die
+ emake || die
+}
+
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc ChangeLog README