summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-10-09 01:39:46 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-10-09 01:39:46 +0000
commit4d15e00ad3c5579eca347dc177174a20397a7e84 (patch)
treeb5ae4bfb3942bf1ecd0019d082164aa34619cc4a /games-fps/ut2004-unwheel
parentLinux patches 2.6.30.8 and 2.6.30.9. Patch cc1 options to ensure -fPIC is not... (diff)
downloadgentoo-2-4d15e00ad3c5579eca347dc177174a20397a7e84.tar.gz
gentoo-2-4d15e00ad3c5579eca347dc177174a20397a7e84.tar.bz2
gentoo-2-4d15e00ad3c5579eca347dc177174a20397a7e84.zip
EAPI=2; RESTRICT=fetch
(Portage version: 2.2_rc44/cvs/Linux x86_64)
Diffstat (limited to 'games-fps/ut2004-unwheel')
-rw-r--r--games-fps/ut2004-unwheel/ChangeLog6
-rw-r--r--games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild32
2 files changed, 24 insertions, 14 deletions
diff --git a/games-fps/ut2004-unwheel/ChangeLog b/games-fps/ut2004-unwheel/ChangeLog
index 4da2284bc8cf..da983882138d 100644
--- a/games-fps/ut2004-unwheel/ChangeLog
+++ b/games-fps/ut2004-unwheel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/ut2004-unwheel
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-unwheel/ChangeLog,v 1.4 2009/03/02 01:35:48 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-unwheel/ChangeLog,v 1.5 2009/10/09 01:39:46 nyhm Exp $
+
+ 09 Oct 2009; Tristan Heaven <nyhm@gentoo.org>
+ ut2004-unwheel-0_beta5.ebuild:
+ EAPI=2; RESTRICT=fetch
02 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org>
ut2004-unwheel-0_beta5.ebuild:
diff --git a/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild b/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild
index a0a9ac7caf19..3e2d616f50f8 100644
--- a/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild
+++ b/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild
@@ -1,27 +1,33 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild,v 1.4 2009/10/01 22:18:22 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/ut2004-unwheel/ut2004-unwheel-0_beta5.ebuild,v 1.5 2009/10/09 01:39:46 nyhm Exp $
+
+EAPI=2
MOD_DESC="multiplayer driving mod focusing on fun driving"
-MOD_NAME="Unwheel"
+MOD_NAME="UnWheel"
MOD_DIR="unwheel"
-inherit versionator games games-mods
-
-MY_PV=$(get_version_component_range 2-2)
-MY_PV=${PV/0_beta/r}
-MY_PN="unwheel"
+inherit games games-mods
HOMEPAGE="http://unwheel.beyondunreal.com/"
-SRC_URI="mirror://beyondunreal/${MY_PN}/${MY_PN}_${MY_PV}.zip
- mirror://beyondunreal/${MY_PN}/packs/UnWheel-R5_BonusPack-Volume_1.zip"
+SRC_URI="unwheel_r5.zip
+ UnWheel-R5_BonusPack-Volume_1.zip"
-LICENSE="as-is"
+LICENSE="freedist"
KEYWORDS="amd64 x86"
IUSE="dedicated opengl"
+RESTRICT="fetch"
+
+pkg_nofetch() {
+ elog "Please download the following files:"
+ elog "http://www.filefront.com/5110896"
+ elog "http://www.filefront.com/13792114"
+ elog "and move them to ${DISTDIR}"
+}
src_unpack() {
- mkdir -p ${MOD_DIR}
- unzip "${DISTDIR}"/${MY_PN}_${MY_PV}.zip -d ${MOD_DIR}
- unzip "${DISTDIR}"/UnWheel-R5_BonusPack-Volume_1.zip -d ${MOD_DIR}
+ mkdir ${MOD_DIR}
+ cd ${MOD_DIR}
+ unpack ${A}
}