summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-07-06 08:13:03 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-07-06 08:13:03 +0000
commitfc4c3cd2c53b770a64705ec9aae83934a4a12db3 (patch)
treee598e0aa0a579964038fc1bfcd2a19babf6b34c4 /media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
parentInitial commit (diff)
downloadgentoo-2-fc4c3cd2c53b770a64705ec9aae83934a4a12db3.tar.gz
gentoo-2-fc4c3cd2c53b770a64705ec9aae83934a4a12db3.tar.bz2
gentoo-2-fc4c3cd2c53b770a64705ec9aae83934a4a12db3.zip
Fix build with gcc-4.4 Bug #275911
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild')
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild b/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
index 2bf8140638e5..3c6930fe27c0 100644
--- a/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
+++ b/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild,v 1.1 2008/11/19 14:47:42 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.6.1-r1.ebuild,v 1.2 2009/07/06 08:13:03 tupone Exp $
+EAPI=2
inherit eutils autotools
@@ -13,7 +14,7 @@ SRC_URI="mirror://sourceforge/worldforge/${MY_P}.tar.bz2"
SLOT="0"
LICENSE="LGPL-2.1"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="bzip2 doc zlib"
+IUSE="doc"
RDEPEND=""
DEPEND="${RDEPEND}
@@ -21,20 +22,15 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${P}-strict-aliasing.patch \
"${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-gcc-4.4.patch \
"${FILESDIR}"/${P}-as-needed.patch
eautoreconf
}
src_compile() {
- econf \
- $(use_enable zlib) \
- $(use_enable bzip2 bzlib) \
- || die "Error: econf failed!"
emake || die "Error: emake failed!"
if use doc; then
emake docs || die "Error: emake failed!"