summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-31 22:23:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-31 22:23:55 +0000
commit55e643133e13edfbeda97735d8f875a8f8802bfe (patch)
tree34ea6603afcc83a966b296d9a6a96aedcf09a8ce /media-libs/suil
parentinherit multilib for get_libdir (diff)
downloadgentoo-2-55e643133e13edfbeda97735d8f875a8f8802bfe.tar.gz
gentoo-2-55e643133e13edfbeda97735d8f875a8f8802bfe.tar.bz2
gentoo-2-55e643133e13edfbeda97735d8f875a8f8802bfe.zip
version bump
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'media-libs/suil')
-rw-r--r--media-libs/suil/ChangeLog7
-rw-r--r--media-libs/suil/suil-0.6.2.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/media-libs/suil/ChangeLog b/media-libs/suil/ChangeLog
index f4c74bd1c1ff..56cbc639cb4c 100644
--- a/media-libs/suil/ChangeLog
+++ b/media-libs/suil/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/suil
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/suil/ChangeLog,v 1.7 2012/05/22 15:41:08 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/suil/ChangeLog,v 1.8 2012/05/31 22:23:55 aballier Exp $
+
+*suil-0.6.2 (31 May 2012)
+
+ 31 May 2012; Alexis Ballier <aballier@gentoo.org> +suil-0.6.2.ebuild:
+ version bump
22 May 2012; Johannes Huber <johu@gentoo.org> suil-0.6.0.ebuild:
Add ~x86 wrt bug #413033
diff --git a/media-libs/suil/suil-0.6.2.ebuild b/media-libs/suil/suil-0.6.2.ebuild
new file mode 100644
index 000000000000..41156ab68478
--- /dev/null
+++ b/media-libs/suil/suil-0.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/suil/suil-0.6.2.ebuild,v 1.1 2012/05/31 22:23:55 aballier Exp $
+
+EAPI=4
+
+inherit base waf-utils
+
+DESCRIPTION="Lightweight C library for loading and wrapping LV2 plugin UIs"
+HOMEPAGE="http://drobilla.net/software/suil/"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk qt4"
+
+RDEPEND="media-libs/lv2
+ gtk? ( x11-libs/gtk+:2 )
+ qt4? ( x11-libs/qt-gui:4 )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/ldconfig.patch" )
+DOCS=( "AUTHORS" "NEWS" "README" )
+
+src_configure() {
+ # otherwise automagic
+ use gtk || sed -i -e 's/gtk+-2.0/DiSaBlEd/' wscript
+ use qt4 || sed -i -e 's/QtGui/DiSaBlEd/' wscript
+ waf-utils_src_configure \
+ "--mandir=/usr/share/man" \
+ "--docdir=/usr/share/doc/${PF}" \
+ $(use doc && echo "--docs")
+}