summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-01 18:54:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-01 18:54:46 +0000
commitf5010172ae5c25e825a19bc54b2c24cd623f0a2d (patch)
treef9733b4044414b09ccabf2b363cb6609c6ec4385 /media-sound/mp3blaster
parentBring unsermake back, was removed too early, still needed by kpowersave (diff)
downloadgentoo-2-f5010172ae5c25e825a19bc54b2c24cd623f0a2d.tar.gz
gentoo-2-f5010172ae5c25e825a19bc54b2c24cd623f0a2d.tar.bz2
gentoo-2-f5010172ae5c25e825a19bc54b2c24cd623f0a2d.zip
Install splay bin and man as splay_mp3blaster to prevent collisions with media-sound/splay
(Portage version: 2.1.2-r12)
Diffstat (limited to 'media-sound/mp3blaster')
-rw-r--r--media-sound/mp3blaster/ChangeLog9
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.2.0.ebuild11
-rw-r--r--media-sound/mp3blaster/mp3blaster-3.2.3.ebuild13
3 files changed, 26 insertions, 7 deletions
diff --git a/media-sound/mp3blaster/ChangeLog b/media-sound/mp3blaster/ChangeLog
index 998476a44a3c..f2b91e2acf77 100644
--- a/media-sound/mp3blaster/ChangeLog
+++ b/media-sound/mp3blaster/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/mp3blaster
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.27 2006/12/11 19:41:57 beandog Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/ChangeLog,v 1.28 2007/03/01 18:54:46 aballier Exp $
+
+ 01 Mar 2007; Alexis Ballier <aballier@gentoo.org> mp3blaster-3.2.0.ebuild,
+ mp3blaster-3.2.3.ebuild:
+ Install splay bin and man as splay_mp3blaster to prevent collisions with
+ media-sound/splay
*mp3blaster-3.2.3 (11 Dec 2006)
diff --git a/media-sound/mp3blaster/mp3blaster-3.2.0.ebuild b/media-sound/mp3blaster/mp3blaster-3.2.0.ebuild
index 69e85777194f..1018004ebbd0 100644
--- a/media-sound/mp3blaster/mp3blaster-3.2.0.ebuild
+++ b/media-sound/mp3blaster/mp3blaster-3.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.0.ebuild,v 1.13 2006/11/23 17:42:23 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.0.ebuild,v 1.14 2007/03/01 18:54:46 aballier Exp $
inherit toolchain-funcs
@@ -32,6 +32,10 @@ src_unpack() {
src_compile() {
local myconf
+ # Prevents collisions with media-sound/splay
+ sed -i "s/splay.1/splay_mp3blaster.1/" Makefile.in\
+ || die "sedding makefile failed"
+ mv splay.1 splay_mp3blaster.1 || die "renaming splay man failed"
### Looks like NAS support is broken, at least with NAS 1.5 and
### mp3player 3.1.1 (Aug 13, agenkin@thpoon.com)
### Ditto nas-1.6c-r1, mp3blaster-3.2.0 (2004.06.23 - eradicator)
@@ -46,5 +50,8 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die
+ # Prevent collisions with media-sound/splay
+ mv "${D}/usr/bin/splay" "${D}/usr/bin/splay_mp3blaster"\
+ || die "moving splay to splay_mp3blaster failed"
dodoc ANNOUNCE AUTHORS CREDITS ChangeLog FAQ NEWS README TODO
}
diff --git a/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild b/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild
index 5eea82bf274e..0136543d8cb9 100644
--- a/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild
+++ b/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild,v 1.1 2006/12/11 19:41:57 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/mp3blaster/mp3blaster-3.2.3.ebuild,v 1.2 2007/03/01 18:54:46 aballier Exp $
inherit toolchain-funcs
@@ -20,6 +20,10 @@ DEPEND=">=sys-libs/ncurses-5.2
src_compile() {
local myconf
+ # Prevents collisions with media-sound/splay
+ sed -i "s/splay.1/splay_mp3blaster.1/" Makefile.in\
+ || die "sedding makefile failed"
+ mv splay.1 splay_mp3blaster.1 || die "renaming splay man failed"
### Looks like NAS support is broken, at least with NAS 1.5 and
### mp3player 3.1.1 (Aug 13, agenkin@thpoon.com)
### Ditto nas-1.6c-r1, mp3blaster-3.2.0 (2004.06.23 - eradicator)
@@ -33,6 +37,9 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die
+ # Prevent collisions with media-sound/splay
+ mv "${D}/usr/bin/splay" "${D}/usr/bin/splay_mp3blaster"\
+ || die "moving splay to splay_mp3blaster failed"
dodoc ANNOUNCE AUTHORS CREDITS ChangeLog FAQ NEWS README TODO
}