summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJesus Rivero <neurogeek@gentoo.org>2011-07-29 13:37:22 +0000
committerJesus Rivero <neurogeek@gentoo.org>2011-07-29 13:37:22 +0000
commitdfa0b08aea8713ea8918a8d09c851578de0db3bf (patch)
tree798108f3daed8ffd5b690df03a8a3c265048728b /media-sound/tunapie/tunapie-2.1.17.ebuild
parentCleanup (diff)
downloadgentoo-2-dfa0b08aea8713ea8918a8d09c851578de0db3bf.tar.gz
gentoo-2-dfa0b08aea8713ea8918a8d09c851578de0db3bf.tar.bz2
gentoo-2-dfa0b08aea8713ea8918a8d09c851578de0db3bf.zip
Python related improvements wrt bug #373637
(Portage version: 2.2.0_alpha46/cvs/Linux i686)
Diffstat (limited to 'media-sound/tunapie/tunapie-2.1.17.ebuild')
-rw-r--r--media-sound/tunapie/tunapie-2.1.17.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-sound/tunapie/tunapie-2.1.17.ebuild b/media-sound/tunapie/tunapie-2.1.17.ebuild
index 84c0bf3e04f0..89cb3d24e408 100644
--- a/media-sound/tunapie/tunapie-2.1.17.ebuild
+++ b/media-sound/tunapie/tunapie-2.1.17.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/tunapie-2.1.17.ebuild,v 1.1 2009/04/30 09:58:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/tunapie/tunapie-2.1.17.ebuild,v 1.2 2011/07/29 13:37:22 neurogeek Exp $
-EAPI=2
+EAPI=3
+PYTHON_DEPEND="2"
inherit eutils multilib python
DESCRIPTION="Directory browser for Radio and TV streams"
@@ -17,6 +18,11 @@ IUSE="offensive"
RDEPEND=">=dev-python/wxpython-2.6"
DEPEND=""
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_prepare() {
sed -i -e "s:/usr/local/share:/usr/$(get_libdir):" ${PN} \
|| die "sed failed"