summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Houser <chouser@gentoo.org>2001-12-20 15:36:37 +0000
committerChris Houser <chouser@gentoo.org>2001-12-20 15:36:37 +0000
commitc5731c778a25dc39390b59543cd23921c5702647 (patch)
treea68fa35132ac590b05897bae30d6e943838f666b /net-libs
parentnew version (diff)
downloadgentoo-2-c5731c778a25dc39390b59543cd23921c5702647.tar.gz
gentoo-2-c5731c778a25dc39390b59543cd23921c5702647.tar.bz2
gentoo-2-c5731c778a25dc39390b59543cd23921c5702647.zip
upgrade
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libesmtp/libesmtp-0.8.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/libesmtp/libesmtp-0.8.6.ebuild b/net-libs/libesmtp/libesmtp-0.8.6.ebuild
new file mode 100644
index 000000000000..00e86180fa79
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-0.8.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/libesmtp-0.8.6.ebuild,v 1.1 2001/12/20 15:35:51 chouser Exp $
+
+A=${P}.tar.bz2
+S=${WORKDIR}/${P}
+DESCRIPTION="libESMTP is a library that implements the client side of the SMTP protocol"
+SRC_URI="http://www.stafford.uklinux.net/libesmtp/${A}"
+HOMEPAGE="http://www.stafford.uklinux.net/libesmtp/index.html"
+
+DEPEND="virtual/glibc
+ >=sys-devel/libtool-1.3.5-r2
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+src_compile() {
+ local myconf
+ use ssl || myconf="$myconf --without-openssl"
+
+ ./configure --prefix=/usr --enable-require-all-recipients $myconf
+ assert "configure failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make prefix=${D}/usr install || die "make install failed"
+ dodoc AUTHORS COPYING COPYING.GPL INSTALL ChangeLog NEWS Notes README TODO doc/api.xml
+}