summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <hans@degraaff.org>2024-04-22 07:42:49 +0200
committerHans de Graaff <hans@degraaff.org>2024-04-22 07:42:49 +0200
commit05d3eefe899d1da7fd0283e6af82a4b9fb762de6 (patch)
tree8a6968ccca333aa8c77f359e6cf230cb86cd2f7c /dev-ruby/active_model_otp
parentdev-ruby/rubocop: add 1.63.2 (diff)
downloadgraaff-05d3eefe899d1da7fd0283e6af82a4b9fb762de6.tar.gz
graaff-05d3eefe899d1da7fd0283e6af82a4b9fb762de6.tar.bz2
graaff-05d3eefe899d1da7fd0283e6af82a4b9fb762de6.zip
dev-ruby/active_model_otp: add 2.3.4
Signed-off-by: Hans de Graaff <hans@degraaff.org>
Diffstat (limited to 'dev-ruby/active_model_otp')
-rw-r--r--dev-ruby/active_model_otp/Manifest1
-rw-r--r--dev-ruby/active_model_otp/active_model_otp-2.3.4.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/active_model_otp/Manifest b/dev-ruby/active_model_otp/Manifest
index 5e7ebfed..40df37ea 100644
--- a/dev-ruby/active_model_otp/Manifest
+++ b/dev-ruby/active_model_otp/Manifest
@@ -1 +1,2 @@
DIST active_model_otp-2.3.2.tar.gz 10446 BLAKE2B c9ea5a637d0c91ff74ba3a4144182b880698be11505ee01a72b13bc984f83e3ea05da672f05ab9dedbc1c66016aa62b7fc93d5f677eed2f39cbb64f0f6e600ae SHA512 5347d9c727061dcb0f03e843db44868494720398a5578f82bcd79ed54b10041ec8e2893c05148d358edf8207ef1cbfe074fac9624797f38f41ef9a710f34ffd2
+DIST active_model_otp-2.3.4.tar.gz 10456 BLAKE2B b45027739fb00ca0eb435c7797595e7dab601e00b5957fbcb0d90acec6a9e8b40f12ce35c68991b69ec0f4f844e8c92b0a7bbc611e51ba9ca24b0f51dc3d8f8b SHA512 5df0fe70e1e2073181e36ce23f383fdb5564b878a00ba11b586093e13dc80b819ff5a2b50e64c918e989d1718b9cddbe27c336e15e58748978d1470a1199575d
diff --git a/dev-ruby/active_model_otp/active_model_otp-2.3.4.ebuild b/dev-ruby/active_model_otp/active_model_otp-2.3.4.ebuild
new file mode 100644
index 00000000..5bf7fd10
--- /dev/null
+++ b/dev-ruby/active_model_otp/active_model_otp-2.3.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds methods to set and authenticate against one time passwords"
+HOMEPAGE="https://github.com/heapsource/active_model_otp"
+SRC_URI="https://github.com/heapsource/active_model_otp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend "
+ dev-ruby/activemodel:*
+ =dev-ruby/rotp-6.3*
+"