summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-08-22 12:52:41 +0200
committerMike Gilbert <floppym@gentoo.org>2017-08-22 10:20:14 -0400
commitd98aef2054800e6990ae49e817579eb50ddd08d2 (patch)
tree2d604b2671d23e18a269df53450d160e350c2d2f /app-i18n/opencc
parentapp-i18n/opencc: Minor cleanup. (diff)
downloadgentoo-d98aef2054800e6990ae49e817579eb50ddd08d2.tar.gz
gentoo-d98aef2054800e6990ae49e817579eb50ddd08d2.tar.bz2
gentoo-d98aef2054800e6990ae49e817579eb50ddd08d2.zip
app-i18n/opencc: Add live ebuild.
Diffstat (limited to 'app-i18n/opencc')
-rw-r--r--app-i18n/opencc/opencc-1.0.5.ebuild16
-rw-r--r--app-i18n/opencc/opencc-9999.ebuild53
2 files changed, 68 insertions, 1 deletions
diff --git a/app-i18n/opencc/opencc-1.0.5.ebuild b/app-i18n/opencc/opencc-1.0.5.ebuild
index 3e9033333de3..50bab76e2c03 100644
--- a/app-i18n/opencc/opencc-1.0.5.ebuild
+++ b/app-i18n/opencc/opencc-1.0.5.ebuild
@@ -5,9 +5,19 @@ EAPI="6"
inherit cmake-utils
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/BYVoid/OpenCC"
+fi
+
DESCRIPTION="Project for conversion between Traditional and Simplified Chinese"
HOMEPAGE="https://github.com/BYVoid/OpenCC"
-SRC_URI="https://github.com/BYVoid/OpenCC/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/BYVoid/OpenCC/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+fi
LICENSE="Apache-2.0"
SLOT="0/2"
@@ -17,6 +27,10 @@ IUSE="doc"
DEPEND="doc? ( app-doc/doxygen )"
RDEPEND=""
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/OpenCC-ver.${PV}"
+fi
+
DOCS=(AUTHORS NEWS.md README.md)
src_configure() {
diff --git a/app-i18n/opencc/opencc-9999.ebuild b/app-i18n/opencc/opencc-9999.ebuild
new file mode 100644
index 000000000000..8664a59261c8
--- /dev/null
+++ b/app-i18n/opencc/opencc-9999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/BYVoid/OpenCC"
+fi
+
+DESCRIPTION="Project for conversion between Traditional and Simplified Chinese"
+HOMEPAGE="https://github.com/BYVoid/OpenCC"
+if [[ "${PV}" == "9999" ]]; then
+ SRC_URI=""
+else
+ SRC_URI="https://github.com/BYVoid/OpenCC/archive/ver.${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0/2"
+KEYWORDS=""
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+if [[ "${PV}" != "9999" ]]; then
+ S="${WORKDIR}/OpenCC-ver.${PV}"
+fi
+
+DOCS=(AUTHORS NEWS.md README.md)
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_DOCUMENTATION=$(usex doc)
+ -DBUILD_SHARED_LIBS=ON
+ -DENABLE_GTEST=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ if use doc; then
+ mv "${ED}usr/share/opencc/doc/html" "${ED}usr/share/doc/${P}/html" || die
+ rmdir "${ED}usr/share/opencc/doc" || die
+ fi
+}