summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <kangie@gentoo.org>2024-11-12 09:45:06 +1000
committerMatt Jolly <kangie@gentoo.org>2024-11-12 09:45:06 +1000
commit9d912d90da153773ba9f0a36d36e4c53a1edd900 (patch)
treee79e8b06b432d5033ca316da26acfa787460648e /dev-lang
parentrust.eclass: fix typo (diff)
downloadgentoo-9d912d90da153773ba9f0a36d36e4c53a1edd900.tar.gz
gentoo-9d912d90da153773ba9f0a36d36e4c53a1edd900.tar.bz2
gentoo-9d912d90da153773ba9f0a36d36e4c53a1edd900.zip
dev-lang/rust{,-bin}: update GDB/LLDB postinst message
dev-lang/rust was never properly updated and refers to scripts as a singular script. dev-lang/rust-bin was inconsistent with dev-lang/rust; never mentioning LLDB (or doing checks for either). Signed-off-by: Matt Jolly <kangie@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild6
-rw-r--r--dev-lang/rust-bin/rust-bin-1.74.1-r100.ebuild6
-rw-r--r--dev-lang/rust-bin/rust-bin-1.75.0-r100.ebuild6
-rw-r--r--dev-lang/rust-bin/rust-bin-1.77.1-r100.ebuild6
-rw-r--r--dev-lang/rust-bin/rust-bin-1.79.0-r100.ebuild6
-rw-r--r--dev-lang/rust-bin/rust-bin-1.80.1-r100.ebuild6
-rw-r--r--dev-lang/rust-bin/rust-bin-1.81.0-r100.ebuild6
-rw-r--r--dev-lang/rust-bin/rust-bin-1.82.0-r100.ebuild6
-rw-r--r--dev-lang/rust/rust-1.71.1-r100.ebuild4
-rw-r--r--dev-lang/rust/rust-1.74.1-r100.ebuild4
-rw-r--r--dev-lang/rust/rust-1.75.0-r100.ebuild4
-rw-r--r--dev-lang/rust/rust-1.77.1-r100.ebuild4
-rw-r--r--dev-lang/rust/rust-1.79.0-r100.ebuild4
-rw-r--r--dev-lang/rust/rust-1.80.1-r100.ebuild4
-rw-r--r--dev-lang/rust/rust-1.81.0-r100.ebuild4
-rw-r--r--dev-lang/rust/rust-1.82.0-r100.ebuild4
16 files changed, 48 insertions, 32 deletions
diff --git a/dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild b/dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild
index c94b15abb363..50dd03400a4a 100644
--- a/dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.71.1-r100.ebuild
@@ -215,8 +215,10 @@ multilib_src_install() {
pkg_postinst() {
eselect rust update
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+ if has_version dev-debug/gdb || has_version dev-debug/lldb; then
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ fi
if has_version app-editors/emacs; then
elog "install app-emacs/rust-mode to get emacs support for rust."
diff --git a/dev-lang/rust-bin/rust-bin-1.74.1-r100.ebuild b/dev-lang/rust-bin/rust-bin-1.74.1-r100.ebuild
index 9e926b10bbd2..78aa2f6cfdbd 100644
--- a/dev-lang/rust-bin/rust-bin-1.74.1-r100.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.74.1-r100.ebuild
@@ -225,8 +225,10 @@ multilib_src_install() {
pkg_postinst() {
eselect rust update
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+ if has_version dev-debug/gdb || has_version dev-debug/lldb; then
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ fi
if has_version app-editors/emacs; then
elog "install app-emacs/rust-mode to get emacs support for rust."
diff --git a/dev-lang/rust-bin/rust-bin-1.75.0-r100.ebuild b/dev-lang/rust-bin/rust-bin-1.75.0-r100.ebuild
index b551ade199bc..d2250c3b37a1 100644
--- a/dev-lang/rust-bin/rust-bin-1.75.0-r100.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.75.0-r100.ebuild
@@ -225,8 +225,10 @@ multilib_src_install() {
pkg_postinst() {
eselect rust update
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+ if has_version dev-debug/gdb || has_version dev-debug/lldb; then
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ fi
if has_version app-editors/emacs; then
elog "install app-emacs/rust-mode to get emacs support for rust."
diff --git a/dev-lang/rust-bin/rust-bin-1.77.1-r100.ebuild b/dev-lang/rust-bin/rust-bin-1.77.1-r100.ebuild
index b097ab54fc83..0e64474657e5 100644
--- a/dev-lang/rust-bin/rust-bin-1.77.1-r100.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.77.1-r100.ebuild
@@ -227,8 +227,10 @@ multilib_src_install() {
pkg_postinst() {
eselect rust update
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+ if has_version dev-debug/gdb || has_version dev-debug/lldb; then
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ fi
if has_version app-editors/emacs; then
elog "install app-emacs/rust-mode to get emacs support for rust."
diff --git a/dev-lang/rust-bin/rust-bin-1.79.0-r100.ebuild b/dev-lang/rust-bin/rust-bin-1.79.0-r100.ebuild
index cf32754cb8f5..08058a9d05c7 100644
--- a/dev-lang/rust-bin/rust-bin-1.79.0-r100.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.79.0-r100.ebuild
@@ -230,8 +230,10 @@ multilib_src_install() {
pkg_postinst() {
eselect rust update
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+ if has_version dev-debug/gdb || has_version dev-debug/lldb; then
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ fi
if has_version app-editors/emacs; then
elog "install app-emacs/rust-mode to get emacs support for rust."
diff --git a/dev-lang/rust-bin/rust-bin-1.80.1-r100.ebuild b/dev-lang/rust-bin/rust-bin-1.80.1-r100.ebuild
index e792fcab67bd..80683713c412 100644
--- a/dev-lang/rust-bin/rust-bin-1.80.1-r100.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.80.1-r100.ebuild
@@ -234,8 +234,10 @@ multilib_src_install() {
pkg_postinst() {
eselect rust update
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+ if has_version dev-debug/gdb || has_version dev-debug/lldb; then
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ fi
if has_version app-editors/emacs; then
elog "install app-emacs/rust-mode to get emacs support for rust."
diff --git a/dev-lang/rust-bin/rust-bin-1.81.0-r100.ebuild b/dev-lang/rust-bin/rust-bin-1.81.0-r100.ebuild
index 37da74831b9c..7d63e6e075b8 100644
--- a/dev-lang/rust-bin/rust-bin-1.81.0-r100.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.81.0-r100.ebuild
@@ -232,8 +232,10 @@ multilib_src_install() {
pkg_postinst() {
eselect rust update
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+ if has_version dev-debug/gdb || has_version dev-debug/lldb; then
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ fi
if has_version app-editors/emacs; then
optfeature "emacs support for rust" app-emacs/rust-mode
diff --git a/dev-lang/rust-bin/rust-bin-1.82.0-r100.ebuild b/dev-lang/rust-bin/rust-bin-1.82.0-r100.ebuild
index 0491c7a35450..7dbc27333e5c 100644
--- a/dev-lang/rust-bin/rust-bin-1.82.0-r100.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.82.0-r100.ebuild
@@ -234,8 +234,10 @@ multilib_src_install() {
pkg_postinst() {
eselect rust update
- elog "Rust installs a helper script for calling GDB now,"
- elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV}."
+ if has_version dev-debug/gdb || has_version dev-debug/lldb; then
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ fi
if has_version app-editors/emacs; then
optfeature "emacs support for rust" app-emacs/rust-mode
diff --git a/dev-lang/rust/rust-1.71.1-r100.ebuild b/dev-lang/rust/rust-1.71.1-r100.ebuild
index 4207e971e6a8..75c3d5cb771b 100644
--- a/dev-lang/rust/rust-1.71.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.71.1-r100.ebuild
@@ -628,8 +628,8 @@ pkg_postinst() {
eselect rust update
if has_version dev-debug/gdb || has_version dev-debug/lldb; then
- elog "Rust installs a helper script for calling GDB and LLDB,"
- elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
if has_version app-editors/emacs; then
diff --git a/dev-lang/rust/rust-1.74.1-r100.ebuild b/dev-lang/rust/rust-1.74.1-r100.ebuild
index 162ce69c5340..eb2f5da602b4 100644
--- a/dev-lang/rust/rust-1.74.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.74.1-r100.ebuild
@@ -657,8 +657,8 @@ pkg_postinst() {
eselect rust update
if has_version dev-debug/gdb || has_version dev-debug/lldb; then
- elog "Rust installs a helper script for calling GDB and LLDB,"
- elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
if has_version app-editors/emacs; then
diff --git a/dev-lang/rust/rust-1.75.0-r100.ebuild b/dev-lang/rust/rust-1.75.0-r100.ebuild
index ae3ba52f7c38..8b6de6276bce 100644
--- a/dev-lang/rust/rust-1.75.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.75.0-r100.ebuild
@@ -659,8 +659,8 @@ pkg_postinst() {
eselect rust update
if has_version dev-debug/gdb || has_version dev-debug/lldb; then
- elog "Rust installs a helper script for calling GDB and LLDB,"
- elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
if has_version app-editors/emacs; then
diff --git a/dev-lang/rust/rust-1.77.1-r100.ebuild b/dev-lang/rust/rust-1.77.1-r100.ebuild
index 649a30d32e85..6de3dceb2d04 100644
--- a/dev-lang/rust/rust-1.77.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.77.1-r100.ebuild
@@ -658,8 +658,8 @@ pkg_postinst() {
eselect rust update
if has_version dev-debug/gdb || has_version dev-debug/lldb; then
- elog "Rust installs a helper script for calling GDB and LLDB,"
- elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
if has_version app-editors/emacs; then
diff --git a/dev-lang/rust/rust-1.79.0-r100.ebuild b/dev-lang/rust/rust-1.79.0-r100.ebuild
index 2b16ec509faa..3d9b91670a92 100644
--- a/dev-lang/rust/rust-1.79.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.79.0-r100.ebuild
@@ -661,8 +661,8 @@ pkg_postinst() {
eselect rust update
if has_version dev-debug/gdb || has_version dev-debug/lldb; then
- elog "Rust installs a helper script for calling GDB and LLDB,"
- elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
if has_version app-editors/emacs; then
diff --git a/dev-lang/rust/rust-1.80.1-r100.ebuild b/dev-lang/rust/rust-1.80.1-r100.ebuild
index ac7cf1cda9dc..adfdb2883072 100644
--- a/dev-lang/rust/rust-1.80.1-r100.ebuild
+++ b/dev-lang/rust/rust-1.80.1-r100.ebuild
@@ -660,8 +660,8 @@ pkg_postinst() {
eselect rust update
if has_version dev-debug/gdb || has_version dev-debug/lldb; then
- elog "Rust installs a helper script for calling GDB and LLDB,"
- elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
if has_version app-editors/emacs; then
diff --git a/dev-lang/rust/rust-1.81.0-r100.ebuild b/dev-lang/rust/rust-1.81.0-r100.ebuild
index 45a3b156c9e4..8af903281b73 100644
--- a/dev-lang/rust/rust-1.81.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.81.0-r100.ebuild
@@ -662,8 +662,8 @@ pkg_postinst() {
eselect rust update
if has_version dev-debug/gdb || has_version dev-debug/lldb; then
- elog "Rust installs a helper script for calling GDB and LLDB,"
- elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
if has_version app-editors/emacs; then
diff --git a/dev-lang/rust/rust-1.82.0-r100.ebuild b/dev-lang/rust/rust-1.82.0-r100.ebuild
index fc2eefa52e7c..a1c5754e615c 100644
--- a/dev-lang/rust/rust-1.82.0-r100.ebuild
+++ b/dev-lang/rust/rust-1.82.0-r100.ebuild
@@ -672,8 +672,8 @@ pkg_postinst() {
eselect rust update
if has_version dev-debug/gdb || has_version dev-debug/lldb; then
- elog "Rust installs a helper script for calling GDB and LLDB,"
- elog "for your convenience it is installed under /usr/bin/rust-{gdb,lldb}-${PV}."
+ elog "Rust installs helper scripts for calling GDB and LLDB,"
+ elog "for convenience they are installed under /usr/bin/rust-{gdb,lldb}-${PV}."
fi
if has_version app-editors/emacs; then