summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-11 20:08:17 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-11 20:08:17 -0700
commit6d14995e4eb605b83cc830e4e4417b3a40e133b5 (patch)
treef73e005906c57d1fc8375176d6a9580a110be212 /dev-python/botocore/botocore-9999.ebuild
parentnet-misc/openssh-8.2_p1-r6: Fix libressl patch (diff)
downloadgentoo-6d14995e4eb605b83cc830e4e4417b3a40e133b5.tar.gz
gentoo-6d14995e4eb605b83cc830e4e4417b3a40e133b5.tar.bz2
gentoo-6d14995e4eb605b83cc830e4e4417b3a40e133b5.zip
dev-python/botocore-1.16.7: Bump, remove dep version locks
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/botocore/botocore-9999.ebuild')
-rw-r--r--dev-python/botocore/botocore-9999.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index f9ce3c85acf8..54136d6d4829 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -45,6 +45,10 @@ PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
python_compile_all() {
use doc && emake -C docs html
+
+ # remove version locked deps
+ sed -r -e 's:([a-zA-Z0-9_-]+)[><|=].*:\1:' \
+ -i requirements.txt || die
}
python_test() {