summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2023-10-27 22:11:42 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2023-10-27 22:12:20 +0200
commitfc8b8de231ec20cd7c1a003d1b5270a2949ed966 (patch)
tree798e4969b7129cd059e0d975e12136c904090589 /sys-libs/glibc
parentdev-python/reportlab: Stabilize 4.0.6 arm, #916366 (diff)
downloadgentoo-fc8b8de231ec20cd7c1a003d1b5270a2949ed966.tar.gz
gentoo-fc8b8de231ec20cd7c1a003d1b5270a2949ed966.tar.bz2
gentoo-fc8b8de231ec20cd7c1a003d1b5270a2949ed966.zip
sys-libs/glibc: disable aarch64 mathvec for headers-only
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.38-r7.ebuild9
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.38-r7.ebuild b/sys-libs/glibc/glibc-2.38-r7.ebuild
index 59f45cf9d469..6326864811df 100644
--- a/sys-libs/glibc/glibc-2.38-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.38-r7.ebuild
@@ -1165,7 +1165,15 @@ glibc_headers_configure() {
popd >/dev/null
fi
+ local myconf=()
+
case ${CTARGET} in
+ aarch64*)
+ # The configure checks fail during cross-build, so disable here
+ # for headers-only
+ myconf+=(
+ --disable-mathvec
+ ) ;;
riscv*)
# RISC-V interrogates the compiler to determine which target to
# build. If building the headers then we don't strictly need a
@@ -1184,7 +1192,6 @@ glibc_headers_configure() {
) ;;
esac
- local myconf=()
myconf+=(
--disable-sanity-checks
--enable-hacker-mode
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 41218b9c69d0..512e39736db4 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1165,7 +1165,15 @@ glibc_headers_configure() {
popd >/dev/null
fi
+ local myconf=()
+
case ${CTARGET} in
+ aarch64*)
+ # The configure checks fail during cross-build, so disable here
+ # for headers-only
+ myconf+=(
+ --disable-mathvec
+ ) ;;
riscv*)
# RISC-V interrogates the compiler to determine which target to
# build. If building the headers then we don't strictly need a
@@ -1184,7 +1192,6 @@ glibc_headers_configure() {
) ;;
esac
- local myconf=()
myconf+=(
--disable-sanity-checks
--enable-hacker-mode