summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.38-r7.ebuild9
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild9
2 files changed, 16 insertions, 2 deletions
diff --git a/sys-libs/glibc/glibc-2.38-r7.ebuild b/sys-libs/glibc/glibc-2.38-r7.ebuild
index 59f45cf9d469..6326864811df 100644
--- a/sys-libs/glibc/glibc-2.38-r7.ebuild
+++ b/sys-libs/glibc/glibc-2.38-r7.ebuild
@@ -1165,7 +1165,15 @@ glibc_headers_configure() {
popd >/dev/null
fi
+ local myconf=()
+
case ${CTARGET} in
+ aarch64*)
+ # The configure checks fail during cross-build, so disable here
+ # for headers-only
+ myconf+=(
+ --disable-mathvec
+ ) ;;
riscv*)
# RISC-V interrogates the compiler to determine which target to
# build. If building the headers then we don't strictly need a
@@ -1184,7 +1192,6 @@ glibc_headers_configure() {
) ;;
esac
- local myconf=()
myconf+=(
--disable-sanity-checks
--enable-hacker-mode
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 41218b9c69d0..512e39736db4 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -1165,7 +1165,15 @@ glibc_headers_configure() {
popd >/dev/null
fi
+ local myconf=()
+
case ${CTARGET} in
+ aarch64*)
+ # The configure checks fail during cross-build, so disable here
+ # for headers-only
+ myconf+=(
+ --disable-mathvec
+ ) ;;
riscv*)
# RISC-V interrogates the compiler to determine which target to
# build. If building the headers then we don't strictly need a
@@ -1184,7 +1192,6 @@ glibc_headers_configure() {
) ;;
esac
- local myconf=()
myconf+=(
--disable-sanity-checks
--enable-hacker-mode