summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <blutgens@gentoo.org>2001-09-25 15:58:58 +0000
committerBen Lutgens <blutgens@gentoo.org>2001-09-25 15:58:58 +0000
commit02a34bed71de20d9aa9630f7423b633af850ab8a (patch)
tree983a685d0392b98c78dd3c5e6e21aab2b85b7d2c
parentJames Henstridge's GTK bindings for Python (diff)
downloadhistorical-02a34bed71de20d9aa9630f7423b633af850ab8a.tar.gz
historical-02a34bed71de20d9aa9630f7423b633af850ab8a.tar.bz2
historical-02a34bed71de20d9aa9630f7423b633af850ab8a.zip
cool little c program that calculates the different subnetmask notations.
-rw-r--r--net-misc/whatmask/files/digest-whatmask-1.11
-rw-r--r--net-misc/whatmask/whatmask-1.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/net-misc/whatmask/files/digest-whatmask-1.1 b/net-misc/whatmask/files/digest-whatmask-1.1
new file mode 100644
index 000000000000..eb4042b8a1cf
--- /dev/null
+++ b/net-misc/whatmask/files/digest-whatmask-1.1
@@ -0,0 +1 @@
+MD5 2fa6b1bb18f037d0f9c3c8b2eed19277 whatmask-1.1.tar.gz
diff --git a/net-misc/whatmask/whatmask-1.1.ebuild b/net-misc/whatmask/whatmask-1.1.ebuild
new file mode 100644
index 000000000000..95b4a30284d8
--- /dev/null
+++ b/net-misc/whatmask/whatmask-1.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Ben Lutgens <lamer@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whatmask/whatmask-1.1.ebuild,v 1.1 2001/09/25 15:58:58 lamer Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="little C program to compute different subnet mask notations"
+SRC_URI="http://downloads.laffeycomputer.com/current_builds/whatmask/${P}.tar.gz"
+HOMEPAGE="http://www.laffeycomputer.com/whatmask.html"
+DEPEND="virtual/glibc"
+
+#RDEPEND=""
+
+src_compile() {
+ try ./configure --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST}
+
+ emake || die
+ #make || die
+}
+
+src_install () {
+
+ # try make prefix=${D}/usr install
+
+ try make DESTDIR=${D} install
+ dodoc README INSTALL AUTHORS ChangeLog NEWS
+}
+