summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-02-25 20:10:17 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-02-25 20:10:17 +0000
commitcc0571ab64d61d8683ecc47deff58edf1d85f06c (patch)
tree046bc309cb31d1b397d944f447f71c382d3b4086 /dev-lisp/cl-araneida
parentversion bump (diff)
downloadhistorical-cc0571ab64d61d8683ecc47deff58edf1d85f06c.tar.gz
historical-cc0571ab64d61d8683ecc47deff58edf1d85f06c.tar.bz2
historical-cc0571ab64d61d8683ecc47deff58edf1d85f06c.zip
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'dev-lisp/cl-araneida')
-rw-r--r--dev-lisp/cl-araneida/ChangeLog8
-rw-r--r--dev-lisp/cl-araneida/Manifest6
-rw-r--r--dev-lisp/cl-araneida/cl-araneida-0.9.ebuild20
-rw-r--r--dev-lisp/cl-araneida/files/0.9-gentoo.patch27
-rw-r--r--dev-lisp/cl-araneida/files/README.Gentoo27
5 files changed, 78 insertions, 10 deletions
diff --git a/dev-lisp/cl-araneida/ChangeLog b/dev-lisp/cl-araneida/ChangeLog
index 7e5a7563b555..e96ab12a74ce 100644
--- a/dev-lisp/cl-araneida/ChangeLog
+++ b/dev-lisp/cl-araneida/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/cl-araneida
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-araneida/ChangeLog,v 1.1 2005/02/10 09:18:29 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-araneida/ChangeLog,v 1.2 2005/02/25 20:10:17 mkennedy Exp $
+
+ 25 Feb 2005; Matthew Kennedy <mkennedy@gentoo.org> +files/README.Gentoo,
+ cl-araneida-0.9.ebuild:
+ Correct documentation; Correct documentation installation paths; Add
+ README.Gentoo describing proxy options and departure from documentation
+ standards
*cl-araneida-0.9 (08 Feb 2005)
diff --git a/dev-lisp/cl-araneida/Manifest b/dev-lisp/cl-araneida/Manifest
index 853e9ef16df9..0ea1610ca8fd 100644
--- a/dev-lisp/cl-araneida/Manifest
+++ b/dev-lisp/cl-araneida/Manifest
@@ -1,4 +1,6 @@
-MD5 3fe27525008d3b90c70331ab2139e20d cl-araneida-0.9.ebuild 1061
-MD5 fa7db6c753d7393ae64ccf032ae26563 ChangeLog 420
+MD5 74e3ace760bf307f3c740aed112d8ddd ChangeLog 679
+MD5 2efce1099af4cc87efa8e24c6bd206b5 cl-araneida-0.9.ebuild 1220
MD5 bed806f237a48cfeae6c387d74857eae metadata.xml 1334
+MD5 0dd195e41578ab2ac44af72359a0dd94 files/0.9-gentoo.patch 1251
MD5 ab9016b24624fad7509736318cfa4fbd files/digest-cl-araneida-0.9 64
+MD5 698dfa61c088f6136aab28f4a417edfc files/README.Gentoo 959
diff --git a/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild b/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild
index d22143965162..efb1113bab43 100644
--- a/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild
+++ b/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild,v 1.1 2005/02/10 09:18:29 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-araneida/cl-araneida-0.9.ebuild,v 1.2 2005/02/25 20:10:17 mkennedy Exp $
inherit common-lisp eutils
@@ -11,14 +11,20 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
-DEPEND="net-www/apache
- dev-lisp/cl-split-sequence
+DEPEND="dev-lisp/cl-split-sequence
dev-lisp/cl-net-telent-date"
+RDEPEND="${DEPEND}
+ || ( net-www/apache www-servers/pound )"
CLPACKAGE=araneida
S=${WORKDIR}/araneida_${PV}
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PV}-gentoo.patch || die
+}
+
src_install() {
insinto $CLSOURCEROOT/araneida
doins *.asd *.lisp NEWS
@@ -29,8 +35,8 @@ src_install() {
insinto $CLSOURCEROOT/araneida/doc
doins doc/*.html doc/*.css doc/*.lisp doc/PLAN
common-lisp-system-symlink
- dohtml doc/*.html doc/*.css
- insinto /usr/share/doc/${PF}/examples/
- doins doc/*.lisp
- dodoc doc/*.txt new-dispatch-model
+ dodoc doc/*.txt INSTALL.asdf LICENCE* NEWS Notes README TODO
+ dosym $CLSOURCEROOT/araneida/doc/ \
+ /usr/share/doc/${PF}/html
+ dodoc ${FILESDIR}/README.Gentoo
}
diff --git a/dev-lisp/cl-araneida/files/0.9-gentoo.patch b/dev-lisp/cl-araneida/files/0.9-gentoo.patch
new file mode 100644
index 000000000000..249bf5ee6f70
--- /dev/null
+++ b/dev-lisp/cl-araneida/files/0.9-gentoo.patch
@@ -0,0 +1,27 @@
+diff -ur araneida_0.9.orig/doc/handlers.html araneida_0.9/doc/handlers.html
+--- araneida_0.9.orig/doc/handlers.html 2005-02-25 13:38:51.425932824 -0600
++++ araneida_0.9/doc/handlers.html 2005-02-25 13:39:21.504360208 -0600
+@@ -88,7 +88,7 @@
+
+ <p>HTTP errors (e.g. 404, 500) can be signalled with SIGNAL; see the
+ <a href="example.lisp">example</a>. For a list of condition names,
+-see <a href="../http-errors.lisp">http-errors.lisp</a>.
++see <a href="../http-error.lisp">http-error.lisp</a>.
+
+ <h2>Authentication and authorization methods</h2>
+
+Only in araneida_0.9/doc: handlers.html.~1.7.~
+diff -ur araneida_0.9.orig/doc/html.html araneida_0.9/doc/html.html
+--- araneida_0.9.orig/doc/html.html 2005-02-25 13:38:51.425932824 -0600
++++ araneida_0.9/doc/html.html 2005-02-25 13:44:00.506945368 -0600
+@@ -25,8 +25,7 @@
+ preferred
+
+ <p> We also have a pattern-based rewriting system so that you can
+-"invent your own tags" (sic), using DEFINE-PATTERNS. See example 6 in
+-<a href="../examples/main.lisp">../examples/main.lisp</a>. This is
++"invent your own tags" (sic), using DEFINE-PATTERNS. This is
+ used in the DEFINE-PAGE macro, which also gives you correct handling of
+ conditional GETs for free.
+
+Only in araneida_0.9/doc: html.html.~1.1.~
diff --git a/dev-lisp/cl-araneida/files/README.Gentoo b/dev-lisp/cl-araneida/files/README.Gentoo
new file mode 100644
index 000000000000..6254a08b0dc4
--- /dev/null
+++ b/dev-lisp/cl-araneida/files/README.Gentoo
@@ -0,0 +1,27 @@
+ -*-outline-*-
+* Gentoo Specific Notes for Araneida
+
+** Documentation
+
+Araneida comes with a HTML reference manual. In Gentoo the normal installation
+path for HTML documentation is /usr/share/doc/cl-araneida-*/html/, however
+Araneida's documentation references part of its source code. Indeed the HTML is
+part of its definition system. Therefore, you can find the HTML documentation
+for Araneida at:
+
+ file:///usr/share/common-lisp/source/araneida/doc/index.html
+
+** Reverse Web Proxies
+
+Araneida benifits from a reverse web proxy for deployments, however a proxy
+isn't really required while you develop with Araneida. Nonetheless, the choice
+between two reverse web proxy servers has been included in the runtime
+dependency list:
+
+ net-www/apache
+ www-servers/pound
+
+See the CLiki at http://www.cliki.net/Araneida for more information on this.
+
+--
+Matthew Kennedy <mkennedy@gentoo.org>