summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2003-10-14 21:02:48 +0000
committerTim Yamin <plasmaroo@gentoo.org>2003-10-14 21:02:48 +0000
commitd18474fe2a8b04e7a3ba5a78ba904471e4a0aa29 (patch)
tree4a5b91f6260c64cf0677f923e2287915f5415ec9 /sys-apps/i2c
parenta bit of qa (diff)
downloadhistorical-d18474fe2a8b04e7a3ba5a78ba904471e4a0aa29.tar.gz
historical-d18474fe2a8b04e7a3ba5a78ba904471e4a0aa29.tar.bz2
historical-d18474fe2a8b04e7a3ba5a78ba904471e4a0aa29.zip
Added patch to get this thing to compile on Alpha platforms, Bug #31084.
Diffstat (limited to 'sys-apps/i2c')
-rw-r--r--sys-apps/i2c/ChangeLog6
-rw-r--r--sys-apps/i2c/Manifest7
-rw-r--r--sys-apps/i2c/files/i2c-2.8.0-alphaCompile.patch11
-rw-r--r--sys-apps/i2c/i2c-2.7.0.ebuild9
-rw-r--r--sys-apps/i2c/i2c-2.8.0.ebuild15
5 files changed, 37 insertions, 11 deletions
diff --git a/sys-apps/i2c/ChangeLog b/sys-apps/i2c/ChangeLog
index a19d84e958ae..e7b3f1906281 100644
--- a/sys-apps/i2c/ChangeLog
+++ b/sys-apps/i2c/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for sys-apps/i2c
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/ChangeLog,v 1.7 2003/08/14 09:32:40 johnm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/ChangeLog,v 1.8 2003/10/14 21:02:42 plasmaroo Exp $
+ 14 Oct 2003; <plasmaroo@gentoo.org> i2c-2.7.0.ebuild, i2c-2.8.0.ebuild,
+ files/i2c-2.8.0-alphaCompile.patch:
+ Added a patch to get the code to compile on Alpha platforms and added ~alpha
+ flag: Bug 31084.
*i2c-2.8.0 (13 Aug 2003)
diff --git a/sys-apps/i2c/Manifest b/sys-apps/i2c/Manifest
index 908e209bff3d..f73af35946f7 100644
--- a/sys-apps/i2c/Manifest
+++ b/sys-apps/i2c/Manifest
@@ -1,7 +1,8 @@
+MD5 823bb3a469a3ec5934cfa71e1c48698d i2c-2.8.0.ebuild 3688
+MD5 f35987a862d0cf472e17692391c290e4 ChangeLog 1583
+MD5 511dfa00c3d897f4365d7cb09128deb8 i2c-2.7.0.ebuild 1287
MD5 14e680fd150dbc27e9cb7b28f2c5c27d i2c-2.6.5-r1.ebuild 1194
MD5 3576df9f3c7882d48106168eb8f7d51a files/digest-i2c-2.6.5-r1 61
+MD5 9a742c848861fdb77a2ece979a81edc3 files/i2c-2.8.0-alphaCompile.patch 353
MD5 2e2470d20cbace5964fe8d32fd87200e files/digest-i2c-2.7.0 61
MD5 98815b3534b98fe332ebd0121be2c5c0 files/digest-i2c-2.8.0 61
-MD5 c3d3cdf56b94906d2b7cff5d9088083a i2c-2.8.0.ebuild 3589
-MD5 9b8c85903614372d5bba16dda9892ace ChangeLog 1369
-MD5 b8fa631b12d9a1bd89b22c7a6358fd1f i2c-2.7.0.ebuild 1194
diff --git a/sys-apps/i2c/files/i2c-2.8.0-alphaCompile.patch b/sys-apps/i2c/files/i2c-2.8.0-alphaCompile.patch
new file mode 100644
index 000000000000..cf6ef481a652
--- /dev/null
+++ b/sys-apps/i2c/files/i2c-2.8.0-alphaCompile.patch
@@ -0,0 +1,11 @@
+--- i2c-velleman.c 2003-01-21 10:00:19.000000000 +0000
++++ i2c-velleman.c.plasmaroo 2003-10-14 19:31:11.000000000 +0100
+@@ -20,6 +20,8 @@
+
+ /* $Id: i2c-2.8.0-alphaCompile.patch,v 1.1 2003/10/14 21:02:42 plasmaroo Exp $ */
+
++#include <asm/param.h> // Alpha compile fix
++
+ #include <linux/kernel.h>
+ #include <linux/ioport.h>
+ #include <linux/module.h>
diff --git a/sys-apps/i2c/i2c-2.7.0.ebuild b/sys-apps/i2c/i2c-2.7.0.ebuild
index 65c90857870e..b9146f72dbe0 100644
--- a/sys-apps/i2c/i2c-2.7.0.ebuild
+++ b/sys-apps/i2c/i2c-2.7.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.7.0.ebuild,v 1.7 2003/10/03 15:09:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.7.0.ebuild,v 1.8 2003/10/14 21:02:42 plasmaroo Exp $
DESCRIPTION="I2C Bus support"
HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
@@ -8,11 +8,16 @@ SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ~ppc"
+KEYWORDS="x86 amd64 alpha ~ppc"
DEPEND="virtual/linux-sources"
src_compile() {
+
+ cd kernel;
+ epatch ${FILESDIR}/i2c-2.8.0-alphaCompile.patch > /dev/null;
+ cd ..;
+
if [ ! `emake LINUX_INCLUDE_DIR=/usr/include/linux clean all` ] ; then
eerror "i2c requires the source of a compatible kernel"
eerror "version installed in /usr/src/linux"
diff --git a/sys-apps/i2c/i2c-2.8.0.ebuild b/sys-apps/i2c/i2c-2.8.0.ebuild
index b21cf1218389..0bba18140719 100644
--- a/sys-apps/i2c/i2c-2.8.0.ebuild
+++ b/sys-apps/i2c/i2c-2.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.0.ebuild,v 1.6 2003/10/03 15:09:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/i2c/i2c-2.8.0.ebuild,v 1.7 2003/10/14 21:02:42 plasmaroo Exp $
DESCRIPTION="I2C Bus support for 2.4.x kernels"
HOMEPAGE="http://www2.lm-sensors.nu/~lm78/"
@@ -8,7 +8,7 @@ SRC_URI="http://www2.lm-sensors.nu/~lm78/archive/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
+KEYWORDS="~x86 ~alpha ~amd64 ~ppc"
DEPEND=""
@@ -75,6 +75,10 @@ src_compile () {
fi
fi
+ cd kernel;
+ epatch ${FILESDIR}/i2c-2.8.0-alphaCompile.patch > /dev/null;
+ cd ..;
+
if [ ! `emake LINUX=$LINUX clean all` ] ; then
eerror "i2c requires the source of a compatible kernel"
eerror "version installed in /usr/src/linux"
@@ -101,8 +105,9 @@ pkg_postinst() {
einfo
einfo "I2C modules installed ..."
einfo
- einfo "IMPORTANT ... if you are installing this package you need to"
- einfo "IMPORTANT ... *disable* kernel I2C support OR *modularize it*"
- einfo "IMPORTANT ... if your 2.4.x kernel is patched with such support"
+ ewarn "IMPORTANT ... if you are installing this package you need to"
+ ewarn "IMPORTANT ... *disable* kernel I2C support OR *modularize it*"
+ ewarn "IMPORTANT ... if your 2.4.x kernel is patched with such support"
einfo
+ echo
}