summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Coie <rac@gentoo.org>2003-07-12 02:52:45 +0000
committerRobert Coie <rac@gentoo.org>2003-07-12 02:52:45 +0000
commit8af24c9dad58c85aa4da0f8a16db53a959bcc5cd (patch)
tree98dc28fd256edc74d066ca68999d7a4943d08645 /sys-devel
parentnew version, mark 2.2.2.1 x86 (diff)
downloadhistorical-8af24c9dad58c85aa4da0f8a16db53a959bcc5cd.tar.gz
historical-8af24c9dad58c85aa4da0f8a16db53a959bcc5cd.tar.bz2
historical-8af24c9dad58c85aa4da0f8a16db53a959bcc5cd.zip
add mips config u32align workaround
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/ChangeLog6
-rw-r--r--sys-devel/libperl/Manifest6
-rw-r--r--sys-devel/libperl/libperl-5.8.0.ebuild9
-rw-r--r--sys-devel/libperl/libperl-5.8.1_rc1.ebuild9
4 files changed, 24 insertions, 6 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index bc6723385c74..f2ac16765faa 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.11 2003/07/11 05:57:55 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.12 2003/07/12 02:52:41 rac Exp $
+
+ 11 Jul 2003; <rac@gentoo.org> libperl-5.8.0.ebuild,
+ libperl-5.8.1_rc1.ebuild:
+ Add mips u32align workaround...thanks to Kumba
*libperl-5.8.1_rc1 (10 Jul 2003)
diff --git a/sys-devel/libperl/Manifest b/sys-devel/libperl/Manifest
index 4e3c4495b9dd..27827764a4b9 100644
--- a/sys-devel/libperl/Manifest
+++ b/sys-devel/libperl/Manifest
@@ -1,6 +1,6 @@
-MD5 1fe12c55921b97990fee495084bc1e12 libperl-5.8.1_rc1.ebuild 10655
-MD5 8934d6dc2e238f5253df4bcb05eb8ae6 libperl-5.8.0.ebuild 13410
-MD5 fc0fe5a90b702f1fe8dd1b9b245efdfe ChangeLog 1817
+MD5 d3accd67201ed1e3c15b56f0f2fbe7ac libperl-5.8.1_rc1.ebuild 10874
+MD5 262b4d1ae6927bb7f1617bf078b1f8ac libperl-5.8.0.ebuild 13624
+MD5 ed031696de56674eb8ba89564b478f55 ChangeLog 1949
MD5 ac9dfab35984723656c734b7312bf403 files/digest-libperl-5.8.1_rc1 65
MD5 0bdca74363c218d91a0db4ad1ea55485 files/libperl-5.8.1_rc1-create-libperl-soname.patch 417
MD5 8605f033c451df987f4631bbf9d7b481 files/digest-libperl-5.8.0 64
diff --git a/sys-devel/libperl/libperl-5.8.0.ebuild b/sys-devel/libperl/libperl-5.8.0.ebuild
index 4aa61d914741..3298cb9082cc 100644
--- a/sys-devel/libperl/libperl-5.8.0.ebuild
+++ b/sys-devel/libperl/libperl-5.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.0.ebuild,v 1.13 2003/06/22 06:13:34 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.0.ebuild,v 1.14 2003/07/12 02:52:41 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -191,6 +191,13 @@ src_compile() {
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
+ if [ "`use mips`" ]
+ then
+ # this is needed because gcc 3.3-compiled kernels will hang
+ # the machine trying to run this test - check with `Kumba
+ # <rac@gentoo.org> 2003.06.26
+ myconf="${myconf} -Dd_u32align"
+ fi
if [ "`use sparc`" ]
then
myconf="${myconf} -Ud_longdbl"
diff --git a/sys-devel/libperl/libperl-5.8.1_rc1.ebuild b/sys-devel/libperl/libperl-5.8.1_rc1.ebuild
index 312c1ce4e090..3e6b540cc6d1 100644
--- a/sys-devel/libperl/libperl-5.8.1_rc1.ebuild
+++ b/sys-devel/libperl/libperl-5.8.1_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.1_rc1.ebuild,v 1.1 2003/07/11 05:57:55 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.1_rc1.ebuild,v 1.2 2003/07/12 02:52:41 rac Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -162,6 +162,13 @@ src_compile() {
else
myconf="${myconf} -Ui_db -Ui_ndbm"
fi
+ if [ "`use mips`" ]
+ then
+ # this is needed because gcc 3.3-compiled kernels will hang
+ # the machine trying to run this test - check with `Kumba
+ # <rac@gentoo.org> 2003.06.26
+ myconf="${myconf} -Dd_u32align"
+ fi
if [ "`use sparc`" ]
then
myconf="${myconf} -Ud_longdbl"