summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2005-12-17 21:17:10 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2005-12-17 21:17:10 +0000
commit978ec1040abdbebd8769581a6b28b67ef950dc5e (patch)
treef7b87897cad4b6a9145694e38d7a9d7bebae8c4b /x11-proto/glproto
parentAdded ~ppc64 (diff)
downloadhistorical-978ec1040abdbebd8769581a6b28b67ef950dc5e.tar.gz
historical-978ec1040abdbebd8769581a6b28b67ef950dc5e.tar.bz2
historical-978ec1040abdbebd8769581a6b28b67ef950dc5e.zip
Bump for 7.0RC4.
Package-Manager: portage-2.1_pre1
Diffstat (limited to 'x11-proto/glproto')
-rw-r--r--x11-proto/glproto/ChangeLog8
-rw-r--r--x11-proto/glproto/files/digest-glproto-1.4.21
-rw-r--r--x11-proto/glproto/glproto-1.4.2.ebuild48
3 files changed, 56 insertions, 1 deletions
diff --git a/x11-proto/glproto/ChangeLog b/x11-proto/glproto/ChangeLog
index c21d6627fb83..44a5ebd86e85 100644
--- a/x11-proto/glproto/ChangeLog
+++ b/x11-proto/glproto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/glproto
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.17 2005/10/31 17:38:32 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.18 2005/12/17 21:04:32 joshuabaergen Exp $
+
+*glproto-1.4.2 (17 Dec 2005)
+
+ 17 Dec 2005; Joshua Baergen <joshuabaergen@gentoo.org>
+ +glproto-1.4.2.ebuild:
+ Bump for 7.0RC4.
31 Oct 2005; Donnie Berkholz <spyderous@gentoo.org>;
-glproto-1.4-r1.ebuild, -glproto-1.4.1_pre20051013.ebuild:
diff --git a/x11-proto/glproto/files/digest-glproto-1.4.2 b/x11-proto/glproto/files/digest-glproto-1.4.2
new file mode 100644
index 000000000000..58e74ee8e0d5
--- /dev/null
+++ b/x11-proto/glproto/files/digest-glproto-1.4.2
@@ -0,0 +1 @@
+MD5 784790c21e5566c6c2fb58ba95937271 glproto-1.4.2.tar.bz2 53556
diff --git a/x11-proto/glproto/glproto-1.4.2.ebuild b/x11-proto/glproto/glproto-1.4.2.ebuild
new file mode 100644
index 000000000000..532d2eb9787b
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.2.ebuild,v 1.1 2005/12/17 21:04:32 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+OPENGL_DIR="xorg-x11"
+
+DESCRIPTION="X.Org GL protocol headers"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+RDEPEND=""
+DEPEND="${RDEPEND}
+ app-admin/eselect-opengl"
+
+src_install() {
+ x-modular_src_install
+
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ switch_opengl_implem
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ dodir /usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ local x=""
+ # glext.h added for #54984
+ for x in ${D}/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [ -f ${x} -o -L ${x} ]; then
+ mv -f ${x} ${D}/usr/$(get_libdir)/opengl/${OPENGL_DIR}/include
+ fi
+ done
+ eend 0
+}
+
+switch_opengl_implem() {
+ # Switch to the xorg implementation.
+ # Use new opengl-update that will not reset user selected
+ # OpenGL interface ...
+ echo
+ eselect opengl set --use-old ${OPENGL_DIR}
+}