aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-28 13:52:49 +0200
committerAlessandro Barbieri <lssndrbarbieri@gmail.com>2022-05-28 14:53:30 +0200
commitba81273e0a3981c45da70ac940c6d54df58398bc (patch)
treef0a3ce5bca0eae1e1607697b5d00c8a9a4330f94
parentdev-python/ufoProcessor: unkeyword 1.9.0 for ~x86 (diff)
downloadguru-ba81273e0a3981c45da70ac940c6d54df58398bc.tar.gz
guru-ba81273e0a3981c45da70ac940c6d54df58398bc.tar.bz2
guru-ba81273e0a3981c45da70ac940c6d54df58398bc.zip
sci-libs/ButterflyPACK: fix library linking
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
-rw-r--r--sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild b/sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild
index cd801deea..53099d358 100644
--- a/sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild
+++ b/sci-libs/ButterflyPACK/ButterflyPACK-2.1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit cmake fortran-2
+inherit cmake fortran-2 toolchain-funcs
DESCRIPTION="Mathematical software for solving large-scale dense linear systems"
HOMEPAGE="https://github.com/liuyangzhuan/ButterflyPACK"
@@ -29,11 +29,12 @@ DOCS=( README.md CHANGELOG )
PATCHES=( "${FILESDIR}/${P}-no-examples.patch" )
src_configure() {
+ local pkgc="$(tc-getPKG_CONFIG)"
local mycmakeargs=(
-DBUILD_SHARED_LIBS=ON
- -DTPL_ARPACK_LIBRARIES=$(usex arpack)
- -DTPL_MAGMA_LIBRARIES=$(usex magma)
+ "-DTPL_ARPACK_LIBRARIES=$(${pkgc} --libs arpack)"
+ "-DTPL_MAGMA_LIBRARIES=$(${pkgc} --libs magma)"
)
cmake_src_configure
}