summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 07:04:41 +0100
committerSam James <sam@gentoo.org>2022-07-26 07:22:05 +0100
commit880bd1a2cac26d7a969819e2f3b7180276c53c73 (patch)
tree12347a4f70c42f13f83ff45640111f34ac6e011f /app-text/unpaper/unpaper-7.0.0.ebuild
parentmedia-gfx/imagemagick: add 7.1.0.44 (diff)
downloadgentoo-880bd1a2cac26d7a969819e2f3b7180276c53c73.tar.gz
gentoo-880bd1a2cac26d7a969819e2f3b7180276c53c73.tar.bz2
gentoo-880bd1a2cac26d7a969819e2f3b7180276c53c73.zip
app-text/unpaper: add 7.0.0
Closes: https://bugs.gentoo.org/831607 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text/unpaper/unpaper-7.0.0.ebuild')
-rw-r--r--app-text/unpaper/unpaper-7.0.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-text/unpaper/unpaper-7.0.0.ebuild b/app-text/unpaper/unpaper-7.0.0.ebuild
new file mode 100644
index 000000000000..a26b83763386
--- /dev/null
+++ b/app-text/unpaper/unpaper-7.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Post-processor for scanned and photocopied book pages"
+HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=media-video/ffmpeg-2:0=[encode]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xsl-ns-stylesheets
+ dev-libs/libxslt
+ dev-python/sphinx
+ test? ( dev-python/pytest )
+"