summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-09-20 16:03:12 -0400
committerEli Schwartz <eschwartz@gentoo.org>2024-09-20 17:23:05 -0400
commit4b9aaab55dea04ca5bb75cb5d616b9b743d33e33 (patch)
tree62789c085f62145b021b80adc300150031f001ee /dev-libs
parentdev-util/breakpad: bump to 2023.06.01 and fix musl build (diff)
downloadgentoo-4b9aaab55dea04ca5bb75cb5d616b9b743d33e33.tar.gz
gentoo-4b9aaab55dea04ca5bb75cb5d616b9b743d33e33.tar.bz2
gentoo-4b9aaab55dea04ca5bb75cb5d616b9b743d33e33.zip
dev-libs/argtable: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/argtable/argtable-2.13-r4.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-libs/argtable/argtable-2.13-r4.ebuild b/dev-libs/argtable/argtable-2.13-r4.ebuild
index 2796be33a5f3..2ce65ab42cc9 100644
--- a/dev-libs/argtable/argtable-2.13-r4.ebuild
+++ b/dev-libs/argtable/argtable-2.13-r4.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit libtool
+
MY_PV="$(ver_rs 1 '-')"
MY_P=${PN}${MY_PV}
@@ -21,6 +23,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.13-Fix-undeclared-library-function.patch
)
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
econf \
$(use_enable debug) \