summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 09:56:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 10:51:32 +0100
commit5e13184e78ff282d3cd6cdfc3d346e834913bba9 (patch)
tree26e112193102fff93756b96c79e4d51e28f7bdfa /dev-python/cli_helpers/cli_helpers-2.2.1.ebuild
parentdev-python/cachelib: Bump to 0.6.0 (diff)
downloadgentoo-5e13184e78ff282d3cd6cdfc3d346e834913bba9.tar.gz
gentoo-5e13184e78ff282d3cd6cdfc3d346e834913bba9.tar.bz2
gentoo-5e13184e78ff282d3cd6cdfc3d346e834913bba9.zip
dev-python/cli_helpers: Bump to 2.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cli_helpers/cli_helpers-2.2.1.ebuild')
-rw-r--r--dev-python/cli_helpers/cli_helpers-2.2.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/cli_helpers/cli_helpers-2.2.1.ebuild b/dev-python/cli_helpers/cli_helpers-2.2.1.ebuild
new file mode 100644
index 000000000000..40b1f9e1e864
--- /dev/null
+++ b/dev-python/cli_helpers/cli_helpers-2.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Python helpers for common CLI tasks"
+HOMEPAGE="https://cli-helpers.rtfd.io/"
+SRC_URI="https://github.com/dbcli/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/configobj-5.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tabulate-0.8.0[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest