summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2017-05-23 08:37:33 +0200
committerSlawomir Lis <slis@gentoo.org>2017-05-23 12:37:23 +0200
commit7e420c7e418f5ed973490cd6fd95a72785adcbb5 (patch)
tree47ba9d7a90fd47e769e4c6d4937c341a2f7ba787 /dev-python/djangocms-attributes-field/djangocms-attributes-field-0.2.0.ebuild
parentdev-python/djangocms-admin-style: Version bump to 1.2.7 (diff)
downloadgentoo-7e420c7e418f5ed973490cd6fd95a72785adcbb5.tar.gz
gentoo-7e420c7e418f5ed973490cd6fd95a72785adcbb5.tar.bz2
gentoo-7e420c7e418f5ed973490cd6fd95a72785adcbb5.zip
dev-python/djangocms-attributes-field: Version bump to 0.2.0
Also updated to use PYTHON_USEDEP, reported in bug 618924 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/djangocms-attributes-field/djangocms-attributes-field-0.2.0.ebuild')
-rw-r--r--dev-python/djangocms-attributes-field/djangocms-attributes-field-0.2.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/djangocms-attributes-field/djangocms-attributes-field-0.2.0.ebuild b/dev-python/djangocms-attributes-field/djangocms-attributes-field-0.2.0.ebuild
new file mode 100644
index 000000000000..71ce9bcb530d
--- /dev/null
+++ b/dev-python/djangocms-attributes-field/djangocms-attributes-field-0.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="File plugin for django CMS"
+HOMEPAGE="https://github.com/divio/djangocms-attributes-field"
+SRC_URI="https://github.com/divio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ sed -i 's/find_packages()/find_packages(exclude=["tests"])/g' "${S}/setup.py"
+ eapply_user
+}