summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2017-03-16 01:14:25 -0700
committerZac Medico <zmedico@gentoo.org>2017-03-16 02:17:52 -0700
commit8965d4b2224b3fce3f6946a943ecea4b53292477 (patch)
tree9178f00ca9e7d449245f75f1e4ca72baa92abba1 /dev-python/serpent/serpent-1.19.ebuild
parentmedia-plugins/swh-lv2: Version bump to 1.0.16 (diff)
downloadgentoo-8965d4b2224b3fce3f6946a943ecea4b53292477.tar.gz
gentoo-8965d4b2224b3fce3f6946a943ecea4b53292477.tar.bz2
gentoo-8965d4b2224b3fce3f6946a943ecea4b53292477.zip
dev-python/serpent: version bump to 1.19
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-python/serpent/serpent-1.19.ebuild')
-rw-r--r--dev-python/serpent/serpent-1.19.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/serpent/serpent-1.19.ebuild b/dev-python/serpent/serpent-1.19.ebuild
new file mode 100644
index 000000000000..27e5ec56cd3d
--- /dev/null
+++ b/dev-python/serpent/serpent-1.19.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple serialization library based on ast.literal_eval"
+HOMEPAGE="https://pypi.python.org/pypi/serpent https://github.com/irmen/Serpent"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+# not bundled
+RESTRICT="test"
+
+python_test() {
+ pushd "${S}"/tests >/dev/null || die
+ ${PYTHON} -bb test_serpent.py || die
+ popd >/dev/null || die
+}