summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorQuentin Retornaz <gentoo@retornaz.com>2023-03-29 23:29:39 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-04-18 09:03:25 +0300
commit4989398ca8a55f07c018bca35db3abade6391619 (patch)
tree8c8ae927d3139f1c9899a4e05fdc6fa12b84c150 /dev-qt/qtscxml/qtscxml-6.5.0.ebuild
parentsys-cluster/legion: add 23.03.0 (diff)
downloadgentoo-4989398ca8a55f07c018bca35db3abade6391619.tar.gz
gentoo-4989398ca8a55f07c018bca35db3abade6391619.tar.bz2
gentoo-4989398ca8a55f07c018bca35db3abade6391619.zip
dev-qt/qtscxml: add 6.5.0
Signed-off-by: Quentin Retornaz <gentoo@retornaz.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-qt/qtscxml/qtscxml-6.5.0.ebuild')
-rw-r--r--dev-qt/qtscxml/qtscxml-6.5.0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/qtscxml-6.5.0.ebuild b/dev-qt/qtscxml/qtscxml-6.5.0.ebuild
new file mode 100644
index 000000000000..1016e87c11b7
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.5.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*
+ =dev-qt/qtdeclarative-${PV}*
+"
+RDEPEND="
+ ${DEPEND}
+"