summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-18 03:02:18 +0100
committerSam James <sam@gentoo.org>2023-08-18 10:22:31 +0100
commit84bffb47c84bc57fbbd409a72e5ae3d1cdb8cf9e (patch)
treeb43572a69dec4b9a0f1f2d637bb453d008b9da5a /sys-devel
parentapp-doc/gimp-help: Stabilize 2.10.34-r2 amd64, #912443 (diff)
downloadgentoo-84bffb47c84bc57fbbd409a72e5ae3d1cdb8cf9e.tar.gz
gentoo-84bffb47c84bc57fbbd409a72e5ae3d1cdb8cf9e.tar.bz2
gentoo-84bffb47c84bc57fbbd409a72e5ae3d1cdb8cf9e.zip
sys-devel/clang-common: update for newer libcxx
Newer libcxx (>=17) uses _LIBCPP_ENABLE_HARDENED_MODE instead of _LIBCPP_ENABLE_ASSERTIONS which is now deprecated. Closes: https://bugs.gentoo.org/912223 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0.9999.ebuild3
-rw-r--r--sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild (renamed from sys-devel/clang-common/clang-common-17.0.0_rc2.ebuild)3
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0.9999.ebuild3
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild3
-rw-r--r--sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild3
5 files changed, 10 insertions, 5 deletions
diff --git a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0.9999.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi
diff --git a/sys-devel/clang-common/clang-common-17.0.0_rc2.ebuild b/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-17.0.0_rc2.ebuild
+++ b/sys-devel/clang-common/clang-common-17.0.0_rc2-r1.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi
diff --git a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0.9999.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230803.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi
diff --git a/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild b/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild
index 9295c64406f2..a64e6b0f2602 100644
--- a/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild
+++ b/sys-devel/clang-common/clang-common-18.0.0_pre20230810.ebuild
@@ -142,7 +142,8 @@ src_install() {
# Analogue to GLIBCXX_ASSERTIONS
# https://libcxx.llvm.org/UsingLibcxx.html#assertions-mode
- -D_LIBCPP_ENABLE_ASSERTIONS=1
+ # https://libcxx.llvm.org/Hardening.html#using-hardened-mode
+ -D_LIBCPP_ENABLE_HARDENED_MODE=1
EOF
fi