summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Kuhn <stefan.kuhn@foss-group.ch>2012-12-15 16:56:50 +0100
committerStefan Kuhn <stefan.kuhn@foss-group.ch>2012-12-15 16:56:50 +0100
commitc7702caf72f3fab0f9ebc946662aed68d62be074 (patch)
tree8785aa308f78ba77ef489651008eeb2ef155dd89
parentsys-firmware/edk2-bin: fixed Manifest (diff)
downloadwuodan-c7702caf72f3fab0f9ebc946662aed68d62be074.tar.gz
wuodan-c7702caf72f3fab0f9ebc946662aed68d62be074.tar.bz2
wuodan-c7702caf72f3fab0f9ebc946662aed68d62be074.zip
ys-firmware/edk2*: replaced flag "kvm" by "qemu"
-rw-r--r--sys-firmware/edk2-bin/Manifest4
-rw-r--r--sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild18
-rw-r--r--sys-firmware/edk2-bin/metadata.xml2
-rw-r--r--sys-firmware/edk2/Manifest4
-rw-r--r--sys-firmware/edk2/edk2-9999-r11337.ebuild30
-rw-r--r--sys-firmware/edk2/metadata.xml2
6 files changed, 30 insertions, 30 deletions
diff --git a/sys-firmware/edk2-bin/Manifest b/sys-firmware/edk2-bin/Manifest
index 15149c6..dc32627 100644
--- a/sys-firmware/edk2-bin/Manifest
+++ b/sys-firmware/edk2-bin/Manifest
@@ -1,3 +1,3 @@
DIST edk2-bin-9999-r11337.tar.gz 750518 SHA256 053bdb2f0b43a4b9e010f0bbf148889d7440394633e5642f4814bc3f0750c11a SHA512 53734411459ebaf0615ca3a2460d288eb823aaec42159e524dd76bc52903d1d92d5e6d8003f5c6e13cd01f57da831d01224d6b4ce6553d57c5a9b9b3a60c9254 WHIRLPOOL f753baade39d5e5b91cd7baee6a30ed46e3f4a75b96b1c37fe7b45235a10f180b7c8a3c09bee161b999c74ef84250a3907ff6d108d2cf5afab1da519422f84eb
-EBUILD edk2-bin-9999-r11337.ebuild 1414 SHA256 f5f05ccb8e122e7377935866243463dd56926ba2702e8b4a51592d47d6deb04c SHA512 ec2dee0995f9d3b761be97b255d13b5f06b83376343e5bf6767ba58efbe863addaf554f1d003fcc1d964132b8181e9d74bc6acd6398ff276be8b7ace212bf3de WHIRLPOOL 251527f9e6534ad7ea596710eab7b4574863320eec9adcf1a8841e812f84ff5b715c23df92a26004068cc48bf0cf7e34b28b6129f6faa675b438f4585c41c432
-MISC metadata.xml 671 SHA256 d601a51880404882d70005218c430dbc76dd824d8f192f931f7837f6056d5fa7 SHA512 dcae1caa30d0daac3bc93cbd0a58c080da912b81df7e9efc6b17c5343bd592bef8ff0a7ef5f90390f88c555aec5b456587351976ce4f584e02c631dff04d9732 WHIRLPOOL 4fd2b31bdbe469df0aac5bb74568f48f0649806da20a9596fb624ee15091672375e868ff7e28c35177e51cd177d5ef2c0ab5f9aad0d250e412deee32f69ba8a0
+EBUILD edk2-bin-9999-r11337.ebuild 1423 SHA256 af01388e31e5c465c84b587786a324931a988f0ee8110ce902df98bc5c216a36 SHA512 225bbe2aed4cdbbd17150179323a06ed599678290bc02a30d747e8adb138f9ad55a436d9a0fcc6bac8450e023be16f4dc11b5ebb2718fe98d53ec9ba1af065ef WHIRLPOOL c0551d114c54915de7f344e9e7e4c4688e04d2e89caa571d077268bef36e3111c25a1aff5c2e20f6987a0e6a308ff68fe61bd253cfb815a9ff3cfabb8b73d469
+MISC metadata.xml 672 SHA256 d87feea511e3f877972e2064c6715cb96706e3fdc2ff7389a07ce2497cb96a20 SHA512 dbf559ed1ce54eccbf5200e80fddc810f0bcc2609c791c9d9cd5d7adde1a0d807019f1c74ec20434d3ec193501a7d9ed8535a17f20d2e3a201ae841dcd29e7ad WHIRLPOOL bcc228c1b726913712d0b6402cc0b20f31f1381c376fc2ef456350781236e926bd36c90b18efd88ee593cf4ec0664c12bd1bf4fe5793ff136a293613031862d1
diff --git a/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild b/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild
index caa0be0..bd36458 100644
--- a/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild
+++ b/sys-firmware/edk2-bin/edk2-bin-9999-r11337.ebuild
@@ -11,11 +11,11 @@ SRC_URI="http://pentoo-uefi.googlecode.com/files/${PF}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="hello-world kvm shell"
-REQUIRED_USE="|| ( hello-world kvm shell )"
+IUSE="hello-world qemu shell"
+REQUIRED_USE="|| ( hello-world qemu shell )"
DEPEND=""
-RDEPEND="kvm? ( >=app-emulation/qemu-0.9.1 )"
+RDEPEND="qemu? ( >=app-emulation/qemu-0.9.1 )"
# S="$(dirname ${S})"
S="${WORKDIR}/${PF}"
@@ -27,11 +27,11 @@ src_install(){
doins "startup.nsh"
fi
- if use kvm; then
- insinto "/usr/share/${PN}/kvm"
+ if use qemu; then
+ insinto "/usr/share/${PN}/qemu"
newins OVMF.fd uefibios.bin
newins CirrusLogic5446.rom vgabios-cirrus.bin
- dosym "../${PN}/kvm/uefibios.bin" /usr/share/qemu/uefibios-bin.bin
+ dosym "../${PN}/qemu/uefibios.bin" /usr/share/qemu/uefibios-bin.bin
fi
if use shell; then
@@ -41,11 +41,11 @@ src_install(){
}
pkg_postinst() {
- use kvm && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
+ use qemu && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
if use hello-world; then
einfo "A sample HelloWorld.efi was installed in /usr/share/${PN}/hello-world."
- if use kvm; then
- einfo "To test the uefi support in kvm, simply run:"
+ if use qemu; then
+ einfo "To test the uefi support in qemu, simply run:"
einfo " qemu-kvm -hda fat:/usr/share/${PN}/hello-world -bios uefibios-bin.bin"
einfo "and await the message 'UEFI Hello World!' before the shell prompt appears."
fi
diff --git a/sys-firmware/edk2-bin/metadata.xml b/sys-firmware/edk2-bin/metadata.xml
index c01efac..34cfb9b 100644
--- a/sys-firmware/edk2-bin/metadata.xml
+++ b/sys-firmware/edk2-bin/metadata.xml
@@ -12,7 +12,7 @@ environment for the UEFI and PI specifications.
<use>
<flag name="hello-world">Creates a HelloWorld.efi, ready to use with
<pkg>app-emulation/qemu</pkg>.</flag>
-<flag name="kvm">Creates the uefi-bios for <pkg>app-emulation/qemu</pkg>.</flag>
+<flag name="qemu">Creates the uefi-bios for <pkg>app-emulation/qemu</pkg>.</flag>
<flag name="shell">Creates the uefi-shell.</flag>
</use>
</pkgmetadata>
diff --git a/sys-firmware/edk2/Manifest b/sys-firmware/edk2/Manifest
index fc553dc..1e3bdf9 100644
--- a/sys-firmware/edk2/Manifest
+++ b/sys-firmware/edk2/Manifest
@@ -1,2 +1,2 @@
-EBUILD edk2-9999-r11337.ebuild 6352 SHA256 43a663619ff2144e81b4a17ab527ca226535984ab73735b178efbf1d070a9d93 SHA512 c8969c0670c9490812e9178c80d9c6d075023d3a213b2e38af5d0611210f3089f46c7265ab708cc93ff0a5e648bcf8247be70d3ce9d574a0b20788491c184e04 WHIRLPOOL 37458d6e386d1b6cf982a7958908e70d0d1ce6bdc19e1687098c386e6350db66554dfbe052013b501cdafc65372a0863753e45949e5e066269ed3f7cadf7a552
-MISC metadata.xml 626 SHA256 9cc1ab2c024ace64cc357bfd5c2b8c6c895c742eceff28474b1ba37fd12d2927 SHA512 b356ef114162aed2cf44a34643ea98e34a78589d3a415cc60112f6915ec4fb099640447715f52a7ae65f08ba12a20f97b86906903fd04e05ca9a39f1f16c72e8 WHIRLPOOL 84830f9d816beeb83d7c743469bf360433006ae5d2eaef9f479d87127b555410442ce7f5bf29b6f207408a28a1fdc6c3c444a77c32d9e5da479c76042f926fe6
+EBUILD edk2-9999-r11337.ebuild 6367 SHA256 49fdeabb2b5f1625ba0bc08d8ab40f3613188a32d445afb93f4cb481a40a7ad9 SHA512 3f2c57ced4b2d24c51b47ab04f26d49199fa36647f165f6dac35322a38930fa7df362fdc26426a0732d02d1da1d4bac9eafa875af047a27b6a361a3f31fb2173 WHIRLPOOL ba87031baa9dcb072c8410cea8bc154f08961ca23490a063e18b9933117dd33ff6af9032bcc087cf8f27489c46f9794a1cd283e191c64e1bc8d193c964423358
+MISC metadata.xml 627 SHA256 8a345ed8ab4d2f3e7f53569d2c895bc7b01802c89e75261ff89a55bf410b12ca SHA512 86652e9b36e94196b7a50105b370877f17554a220e121a68533ce792aa6e72b7ae83b8bdb4252399d7f95c84dd42283422baf37292c369a57851bf4a5272d269 WHIRLPOOL dd6768485f5e3e4a02c017c99e10d7eb1a25efccb7a827bb016cf874942b85d8488b98b9504532a4cc8c9ce92c43e99156256d8f05c5e5ca17f47b53d3405066
diff --git a/sys-firmware/edk2/edk2-9999-r11337.ebuild b/sys-firmware/edk2/edk2-9999-r11337.ebuild
index e991c48..cc4cdd4 100644
--- a/sys-firmware/edk2/edk2-9999-r11337.ebuild
+++ b/sys-firmware/edk2/edk2-9999-r11337.ebuild
@@ -19,19 +19,19 @@ ESVN_REPO_URI="http://edk2.svn.sourceforge.net/svnroot/edk2/trunk/edk2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64"
-IUSE="hello-world kvm shell"
-REQUIRED_USE="|| ( hello-world kvm shell )"
+IUSE="hello-world qemu shell"
+REQUIRED_USE="|| ( hello-world qemu shell )"
DEPEND="
app-arch/unzip
sys-devel/binutils
sys-libs/glibc
>=dev-vcs/subversion-1.5
- kvm? (
+ qemu? (
>=app-emulation/qemu-0.9.1
sys-power/iasl
)"
-RDEPEND="kvm? ( >=app-emulation/qemu-0.9.1 )"
+RDEPEND="qemu? ( >=app-emulation/qemu-0.9.1 )"
S="$(dirname ${S})"
@@ -54,7 +54,7 @@ src_unpack(){
MdePkg
MdeModulePkg
"
- use kvm && repo_pkg+="
+ use qemu && repo_pkg+="
OvmfPkg
OptionRomPkg
UefiCpuPkg
@@ -64,7 +64,7 @@ src_unpack(){
EdkShellBinPkg
IntelFrameworkPkg
"
- ( use kvm || use shell ) && repo_pkg+="
+ ( use qemu || use shell ) && repo_pkg+="
ShellPkg
"
einfo "### Be patient! ###"
@@ -106,7 +106,7 @@ src_prepare(){
-e "s/^(CXX *= *).*$/\1`echo "${CFLAGS}"`/" \
"BaseTools/Source/C/VfrCompile/Pccts/${file}" || die "Failed to patch compiler flags in ${file}"
done
- # filter our -march, building for kvm guest!
+ # filter our -march, building for qemu guest!
filter-flags -march*
sed -i -r \
-e "s/gcc[[:space:]]*$/`tc-getCC`/" \
@@ -137,12 +137,12 @@ src_compile(){
build --arch "${ARCH}" --platform MdeModulePkg/MdeModulePkg.dsc --tagname "${TAGNAME}" \
--module MdeModulePkg/Application/HelloWorld/HelloWorld.inf \
--buildtarget RELEASE || die "Failed to build HelloWorld"
- # create startup.nsh for kvm testing
+ # create startup.nsh for qemu testing
echo "fs0:\HelloWorld.efi" > Build/MdeModule/RELEASE_GCC45/X64/startup.nsh || die "Failed to
create startup.nsh"
fi
- if use kvm; then
+ if use qemu; then
build --arch "${ARCH}" --platform OvmfPkg/OvmfPkgX64.dsc --tagname "${TAGNAME}" \
--buildtarget RELEASE || die "Failed to build UEFI-shell"
fi
@@ -164,11 +164,11 @@ src_install(){
doins "Build/MdeModule/RELEASE_${TAGNAME}/X64/startup.nsh"
fi
- if use kvm; then
- insinto "/usr/share/${PN}/kvm"
+ if use qemu; then
+ insinto "/usr/share/${PN}/qemu"
newins Build/OvmfX64/RELEASE_GCC45/FV/OVMF.fd uefibios.bin
newins Build/OvmfX64/RELEASE_GCC45/FV/CirrusLogic5446.rom vgabios-cirrus.bin
- dosym "../${PN}/kvm/uefibios.bin" /usr/share/qemu/uefibios.bin
+ dosym "../${PN}/qemu/uefibios.bin" /usr/share/qemu/uefibios.bin
fi
if use shell; then
@@ -178,11 +178,11 @@ src_install(){
}
pkg_postinst() {
- use kvm && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
+ use qemu && einfo "To use uefi with qemu, start it with '-bios uefibios.bin'"
if use hello-world; then
einfo "A sample HelloWorld.efi was installed in /usr/share/${PN}/hello-world."
- if use kvm; then
- einfo "To test the uefi support in kvm, simply run:"
+ if use qemu; then
+ einfo "To test the uefi support in qemu, simply run:"
einfo " qemu-kvm -hda fat:/usr/share/${PN}/hello-world -bios uefibios.bin"
einfo "and await the message 'UEFI Hello World!' before the shell prompt appears."
fi
diff --git a/sys-firmware/edk2/metadata.xml b/sys-firmware/edk2/metadata.xml
index 4bab2fc..b6cea81 100644
--- a/sys-firmware/edk2/metadata.xml
+++ b/sys-firmware/edk2/metadata.xml
@@ -11,7 +11,7 @@ environment for the UEFI and PI specifications.
<use>
<flag name="hello-world">Creates a HelloWorld.efi, ready to use with
<pkg>app-emulation/qemu</pkg>.</flag>
-<flag name="kvm">Creates the uefi-bios for <pkg>app-emulation/qemu</pkg>.</flag>
+<flag name="qemu">Creates the uefi-bios for <pkg>app-emulation/qemu</pkg>.</flag>
<flag name="shell">Creates the uefi-shell.</flag>
</use>
</pkgmetadata>